Problem with fastcgi and lighttpd

Hi,

After having good time with mongrel_rails, I try to play lighttpd.
Okey, this is my configuration file:

Server.document-root = “/var/www/”
server.document-root = “/home/knight/work/proyek/usm”
fastcgi.server = (“.fcgi” =>
( “localhost” =>
( “min-procs” => 1,
“max-procs” => 5,
“socket” => “/tmp/ruby-railsapp.fcgi.socket”,
“bin-path” => “/home/knight/work/proyek/usm/dispatch.fcgi”
)
))
Server.error-handler-404 = “/dispatch.fcgi”

I got this error:
sudo lighttpd -f /etc/lighttpd/lighttpd.conf
Duplicate config variable in conditional 0 global: fastcgi.server
2006-11-28 19:14:58: (configfile.c.805) source:
/usr/share/lighttpd/include-conf-enabled.pl line: 20 pos: 1 parser
failed somehow near here: (EOL)
2006-11-28 19:14:58: (configfile.c.805) source:
/etc/lighttpd/lighttpd.conf line: 172 pos: 1 parser failed somehow near
here: (EOL)

If I comment this fastcgi line:

server.document-root = “/home/knight/work/proyek/usm”
#fastcgi.server = (“.fcgi” =>
#( “localhost” =>
#( “min-procs” => 1,
#“max-procs” => 5,
#“socket” => “/tmp/ruby-railsapp.fcgi.socket”,
#“bin-path” => “/home/knight/work/proyek/usm/dispatch.fcgi”
#)
#))
Server.error-handler-404 = “/dispatch.fcgi”

I got this message:
sudo lighttpd -f /etc/lighttpd/lighttpd.conf
2006-11-28 19:16:32: (mod_fastcgi.c.1022) execve failed for:
/usr/bin/php4-cgi No such file or directory
2006-11-28 19:16:32: (mod_fastcgi.c.1048) the fastcgi-backend
/usr/bin/php4-cgi failed to start:
2006-11-28 19:16:32: (mod_fastcgi.c.1052) child exited with status 2
/usr/bin/php4-cgi
2006-11-28 19:16:32: (mod_fastcgi.c.1055) if you try do run PHP as
FastCGI backend make sure you use the FastCGI enabled version.
You can find out if it is the right one by executing ‘php -v’ and it
should display ‘(cgi-fcgi)’ in the output, NOT (cgi) NOR (cli)
For more information check
http://www.lighttpd.net/documentation/fastcgi.html#preparing-php-as-a-fastcgi-program
2006-11-28 19:16:32: (mod_fastcgi.c.1060) If this is PHP on Gentoo add
fastcgi to the USE flags
2006-11-28 19:16:32: (mod_fastcgi.c.1356) [ERROR]: spawning fcgi failed.
2006-11-28 19:16:32: (server.c.834) Configuration of plugins failed.
Going down.

Do you know what’s going on?
I use Ubuntu 6.06. I installed libfcgi-dev libfcgi0
libterm-readline-perl-perl lighttpd libpcre3-dev libpcrecpp0 by apt-get.
I installed fcgi by gem.