Problem: MySQL drops first connection then fine

Kia ora all,

Today I updated our server management software from Plesk 8.0 to Plesk
8.01.

Now when a user connects to my rails app they will initially get an
Application Error. If they try again it is fine and continues to be fine
until they pause for too long (approx 2 mins). In the logs I am getting
the following error:

ActiveRecord::StatementInvalid (Mysql::Error: MySQL server has gone
away: SELECT * FROM titles )

I have updated the app to Rails 1.1.4 from 1.0.0 but the problem
persists.

Has anyone come across this before? Anyone else have a server they are
managing with Plesk?

I am using MySQL version 3.23.58, Apache and FastCGI. I have tried
setting the timeout on FastCGI to 900 and min-servers to 2 but it still
happens.

Any help would be greatly appreciated!

Regards
Nathan

Kia ora all,

thought I would update you in my progress :slight_smile:

I have upgrade MySQL to 4.1.20

My PHP apps are working fine.

I have found a bug [that has been fixed] in active record which would
return the same error.

Anybody have any other ideas?

Regards
Nathan

Another progress update,

I have installed and tested with mongrel and the same thing is still
happening.

Does any one have any idea what is causing this?

I have: Updated rails to 1.1.4, updated MySQL and tried mongrel. But
still it always drops a users first connection.

Hoping for some ideas :slight_smile:

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs