Problem deploying with Capistrano PLEASE HELP

Hello everybody!!

I’m a newby rails programmer and i like it a lot!!! I’m in love :smiley: But
now I’m trying to deploy my first app from a developer machine to a
production machin using Capistrano. The production machin will be an
Apache with proxy_balancer and some Mongrel servers…

The BIG problem is when in my development machine I execute the command
“rake memote:cold_deploy”. It shows and error why is trying to execute
“sudo -u user /path/to/app/current/script/spin” -> “command not found”

WHY? I’ve read that when you install Rails, it creates
script/process/reaper script/process/spawner and script/process/spin but
any of my apps has the spin script :frowning:

Please what’s the problem? I’m getting crazy!!!

Why I need this script if I don’t want to use fastcgi?

Thanks in advance!!!

Hi Fernandez,

You should look at your deploy.rb-script and modify the “restart” task.
Just use the commands you use to restart your mongrel cluster.

My setup looks something like this:
run “cd #{release_path} && sudo -u user mongrel_rails cluster::restart
-C /path/to/conf.conf”
sudo “apachectl graceful”

Hope that helps.

/Richard Johansson

Hi Richard

Problem solved!!! Since I was all the morning doing modification to all
de files… lastly I forgot to append the line “require
‘mongrel_cluster/recipes’” to the deploy.rb

Yes I know, I’m stupid :smiley:

Once the line was putted in the correct file all worked flawlessly

Thanks for your reply!! :slight_smile:

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs