# OS X After 1.9 Upgrade I get common errors in ri, gem, etc

**URL:** <https://www.ruby-forum.com/t/os-x-after-1-9-upgrade-i-get-common-errors-in-ri-gem-etc/127201>\
**Category:** Ruby\
**Created:** [January 26, 2008, 3:47am UTC](https://www.ruby-forum.com/t/os-x-after-1-9-upgrade-i-get-common-errors-in-ri-gem-etc/127201 "2008-01-26T03:47:28Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![bogojoker](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/b/a88e57/32.png) [@bogojoker](https://www.ruby-forum.com/u/bogojoker)\
**Post date:** [January 26, 2008, 3:47am UTC](https://www.ruby-forum.com/t/os-x-after-1-9-upgrade-i-get-common-errors-in-ri-gem-etc/127201/1 "2008-01-26T03:47:28Z")

</div>

Around the first of the year I upgraded my OS X 10.5 laptop to Ruby 1.9.  
I just used the default procedure:  
$ autoconf  
$ ./configure  
$ make  
$ make install

I did not use the --prefix option for ./configure. I now have two Ruby  
builds:  
/usr/bin/ruby (1.8.6 came with OS X)  
/usr/local/bin/ruby (1.9 just installed, this is the default if I just  
type ruby in the terminal)

However if I try to run ri (which runs /usr/local/bin/ri) I get the  
following error:  
joe[~]$ ri  
/usr/local/lib/ruby/1.9.0/yaml.rb:9:in `require': no such file to load -- stringio (LoadError) from /usr/local/lib/ruby/1.9.0/yaml.rb:9:in`\<top (required)\>’  
from /usr/local/lib/ruby/1.9.0/rdoc/ri/ri\_descriptions.rb:1:in  
`require' from /usr/local/lib/ruby/1.9.0/rdoc/ri/ri_descriptions.rb:1:in`\<top  
(required)\>’  
from /usr/local/lib/ruby/1.9.0/rdoc/ri/ri\_reader.rb:1:in  
`require' from /usr/local/lib/ruby/1.9.0/rdoc/ri/ri_reader.rb:1:in`\<top  
(required)\>’  
from /usr/local/lib/ruby/1.9.0/rdoc/ri/ri\_driver.rb:5:in  
`require' from /usr/local/lib/ruby/1.9.0/rdoc/ri/ri_driver.rb:5:in`\<top  
(required)\>’  
from /usr/local/bin/ri:43:in `require' from /usr/local/bin/ri:43:in`’

I can still resort to the 1.8.6 version of ri in /usr/bin/ri but it is  
discouraging to have to use 1.8.6 after just installing 1.9. I have the  
same issue with gem:  
joe[~]$ gem  
/usr/local/lib/ruby/1.9.0/yaml.rb:9:in `require': no such file to load -- stringio (LoadError) from /usr/local/lib/ruby/1.9.0/yaml.rb:9:in`\<top (required)\>’  
from /usr/local/lib/ruby/1.9.0/rubygems/config\_file.rb:7:in  
`require' from /usr/local/lib/ruby/1.9.0/rubygems/config_file.rb:7:in`\<top (required)\>’  
from /usr/local/lib/ruby/1.9.0/rubygems/gem\_runner.rb:8:in  
`require' from /usr/local/lib/ruby/1.9.0/rubygems/gem_runner.rb:8:in`\<top (required)\>’  
from /usr/local/bin/gem:9:in `require' from /usr/local/bin/gem:9:in`’

Is there an easy fix to the problem or if I reinstall 1.9 using --prefix  
option will it be any different?

Thanks In Advance!!  
Joseph P.
