Openbase and Rails issue

Greetings, ever helpful Rails community. I’m trying to connect to an
Openbase 9.1.1 database through Rails 1.1.4 on my Mac OSX 10.4.7 box
(Ruby 1.8.4, Openbase driver version 0.7.3, both compiled with gcc 4;
I’ve also got OCI and MySQL drivers out there, as well as the Ruby
OpenLDAP library in case any of those cause conflicts).

When I go into irb and type this:


irb(main):001:0> require ‘openbase’

I get:

=> true


When I go into script/console and type this:

require ‘openbase’

I get:

/usr/local/lib/ruby/site_ruby/1.8/powerpc-darwin8.7.0/openbase.bundle:
[BUG] Bus Error
ruby 1.8.4 (2005-12-24) [powerpc-darwin8.7.0]


which is less useful to me. Has anyone else faced the same issue and
can perhaps tell me what might be causing it?

Thanks much,

James S.
Application Systems Analyst
Arizona Student Unions
University of Arizona

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs