Mysql/Ruby on Mysql 4.0.11?


#1

Does Mysql/Ruby work with Mysql 4.0.11?
I know the requirement is 4.0.22 but it says it may
work for other versions.

Anybody tried it on 4.0.11?


#2

Henry Ortega wrote:

Does Mysql/Ruby work with Mysql 4.0.11?
I know the requirement is 4.0.22 but it says it may
work for other versions.

Anybody tried it on 4.0.11?
I had a problem on 4.0.17 with Rails 1.0. The ‘ENGINE’ table type
specification, which is what migrations use, was introduced in (I think)
4.0.18 but 4.0.17 only recognises ‘TYPE’. It’s an easy patch to Rails
that I can email you if you want.

The only other thing I can think of that might be a problem is the
“x’318569’” binary string literal format. I can’t quite recall when
that was introduced.