MySQL Native Bindings

I was following the hivelogic.com article ‘Building Ruby, Rails,
LightTPD,
and MySQL on Tiger’
http://hivelogic.com/articles/2005/12/01/ruby_rails_lighttpd_mysql_tiger

all went well till the last part, MySQL Native Bindings.

http://weblog.rubyonrails.com/2005/10/30/get-10-15-more-performance-with-mysql-rails/

anyways, i recieved an error:

blinking8s:~ blinking8s$ sudo gem install mysql –
–with-mysql-dir=/usr/local/mysql
Password:
Select which gem to install for your platform (i686-darwin8.7.1)

  1. mysql 2.7.1 (mswin32)
  2. mysql 2.7 (ruby)
  3. mysql 2.6 (ruby)
  4. mysql 2.5.1 (ruby)
  5. Cancel installation

2
Building native extensions. This could take a while…
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.

Provided configuration options:
–with-opt-dir
–without-opt-dir
–with-opt-include
–without-opt-include=${opt-dir}/include
–with-opt-lib
–without-opt-lib=${opt-dir}/lib
–with-make-prog
–without-make-prog
–srcdir=.
–curdir
–ruby=/usr/local/bin/ruby
–with-mysql-config
–without-mysql-config
–with-mysql-dir
–with-mysql-include
–without-mysql-include=${mysql-dir}/include
–with-mysql-lib
–without-mysql-lib=${mysql-dir}/lib
–with-mysqlclientlib
–without-mysqlclientlib
–with-mlib
–without-mlib
–with-mysqlclientlib
–without-mysqlclientlib
–with-zlib
–without-zlib
–with-mysqlclientlib
–without-mysqlclientlib
–with-socketlib
–without-socketlib
–with-mysqlclientlib
–without-mysqlclientlib
–with-nsllib
–without-nsllib
–with-mysqlclientlib
–without-mysqlclientlib

ERROR: While executing gem … (RuntimeError)
ERROR: Failed to build gem native extension.
Gem files will remain installed in
/usr/local/lib/ruby/gems/1.8/gems/mysql-
2.7 for inspection.

Results logged to
/usr/local/lib/ruby/gems/1.8/gems/mysql-2.7/gem_make.out

I have googled for the results and found several solutions, but i am no
unix/server geek…just a photographer who has been enjoying rails
enough
for the last 2 days on his locomotive/mamp setup to try to take it to
the
next step and not have to use some funky configuration paths…

i am running OSX 10.4.7

any help on what i should run to get that working, or do to get rid of
my
mistake, would be awesome…

thanks,

  • Will

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs