MySQL Adaptor on WinXP Dual CPU machine broken?

When I run using webrick on a dual WinXP SP2 machine it crashes
intmittently at random locations.

If the page has no MySQL lookups in it it will go and go forever. The
moment I put one
MyModel.find(:first) into the controller. Webrick starts crashing
again. Crash as in illegal access into low addresses of memory.

I have tried installing MySQL 4.1 and 5 GA as well as uninstalling and
reinstalling Ruby/Rails. No luck. When I move to a Unix or Win32
machine with a single CPU, no problem.

I know there are plenty of users out there running SMP unix boxes. Any
Win32 dual users out there?

Originally I was seeing problems in Apache/FastCGI. Apache was actually
occasionally throwing up an illegal access window with ruby.exe as the
title. I uninstalled Apache and tried to get it going on Webrick and
discovered that even that wasn’t working.

Ray

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs