Mongrel starting problem on new Debian box

Hello world,

I’m having some problems setting up a new Debian deployment box…just
installed the rails stack, mongrel, etc…

When I go to start mongrel I’m getting a weird error I can’t figure out.
Some help please?

-> mongrel_rails start
** Starting Mongrel listening at 0.0.0.0:3000
/usr/lib/ruby/gems/1.8/gems/mongrel-0.3.13.3/lib/mongrel.rb:666:inregister': undefined methodresolve’ for nil:Mongrel::URIClassifier
(NoMethodError)
from /usr/lib/ruby/gems/1.8/gems/mongrel-
0.3.13.3/lib/mongrel.rb:850:in uri' from /usr/lib/ruby/gems/1.8/gems/mongrel- 0.3.13.3/lib/mongrel.rb:1018:indebug’
from /usr/lib/ruby/gems/1.8/gems/mongrel-
0.3.13.3/lib/mongrel.rb:1016:in debug' from /usr/lib/ruby/gems/1.8/gems/mongrel- 0.3.13.3/bin/mongrel_rails:108:incloaker_’
from /usr/lib/ruby/gems/1.8/gems/mongrel-
0.3.13.3/lib/mongrel.rb:832:in listener' from /usr/lib/ruby/gems/1.8/gems/mongrel- 0.3.13.3/bin/mongrel_rails:96:incloaker_’
from /usr/lib/ruby/gems/1.8/gems/mongrel-
0.3.13.3/lib/mongrel.rb:750:in initialize' from /usr/lib/ruby/gems/1.8/gems/mongrel- 0.3.13.3/bin/mongrel_rails:83:inrun’
from /usr/lib/ruby/gems/1.8/gems/mongrel-
0.3.13.3/lib/mongrel/command.rb:199:in `run’
from /usr/lib/ruby/gems/1.8/gems/mongrel-
0.3.13.3/bin/mongrel_rails:235
from /usr/bin/mongrel_rails:18

Seemed to be a ruby installation error on my part. Everything working
lovely
now…

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs