Migration issue


#1

of course, now that I am relying upon migrations, I’m at a loss to
explain why it isn’t working.

I have a system which has production and development and I have a
development system at home where I created all the new code and
migrations.

I committed my changes via svn and used ‘svn update’ to update the live
system.

I started by running the migration on the development system to make
sure it worked and it did…It went from schema_info 1 to 3 and the new
tables and data is there.

I am trying to update the production system and it doesn’t change (even
though schema_info is at value 1 in production db.

$ rake db:migrate environment=production --trace
(in /home/craig/th-db)
** Invoke db:migrate (first_time)
** Invoke environment (first_time)
** Execute environment
** Execute db:migrate
** Invoke db:schema:dump (first_time)
** Invoke environment
** Execute db:schema:dump

That’s it, no new field in existing table (migration 2) and none of the
new tables or data as described in migration 3.

I’m not getting any errors… log/production.log shows nothing of my
efforts.

Suggestions?

Craig


#2

On Sun, 2006-04-16 at 17:30 -0700, Craig W. wrote:

I started by running the migration on the development system to make
** Execute environment


replying to myself…

rake db:migrate RAILS_ENV=production VERSION=3 --trace
and
rake db:migrate RAILS_ENV=test VERSION=3 --trace

worked fine

Craig