Migration in typo

I started using typo recently and tried to add a few things on it. But
when I tried to create a model using

ruby script\generate model travel

it gave me
exists app/models/
exists test/unit/
exists test/fixtures/
create app/models/travel.rb
create test/unit/travel_test.rb
create test/fixtures/travels.yml

I thought there should be a migration file in db/migrate/? then I
created a migration file to go with this model 010_create_travel.rb and
create a table with two columns in it. But the migration fails with the
error below

C:\Java\workspace\blog>rake db:migrate --trace
(in C:/Java/workspace/blog)
rake aborted!
Don’t know how to build task ‘db:migrate’
C:/InstantRails/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:1449:in
[]' C:/InstantRails/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:455:in[]’
C:/InstantRails/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:1906:in
`run’

C:/InstantRails/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:1906:in
`run’

C:/InstantRails/ruby/lib/ruby/gems/1.8/gems/rake-0.7.1/bin/rake:7
C:/InstantRails/ruby/bin/rake.bat:25

does anybody have experience handling this problem. very much
appreciated!!

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs