It seems that acts_as_taggable can not be used under 1.1?


#1

If the acts_as_taggable plugin has been installed via ruby script/plugin
install acts_as_taggable while not acts_astaggable gem installed via gem
install acts_as_taggable,it seems that the plugin can not work at all
under the rails 1.1 enviroment.According to
http://wiki.rubyonrails.org/rails/pages/ActsAsTaggablePluginHowto
the plugin should work under edge rails,but when the document
emerges,such characteriscs as :through,:polymorphic can only be got from
edge rails,and not are available under rails 1.1. The system will give
an error message of can not find any methods in the Tag class
Anybody have met such kinds of situations?


#2

Frank-48 wrote:

[…]The system will give
an error message of can not find any methods in the Tag class
Anybody have met such kinds of situations?
[…]

Do you have another ‘Tag’ in app/model?

http://blog.kuttnhaste.com/articles/2006/03/11/rails-tip-plugins-and-models

Simon

View this message in context:
http://www.nabble.com/It-seems-that-acts_as_taggable-can-not-be-used-under-1.1--t1385348.html#a3725154
Sent from the RubyOnRails Users forum at Nabble.com.


#3

If the acts_as_taggable plugin has been installed via ruby script/plugin
install acts_as_taggable while not acts_astaggable gem installed via gem
install acts_as_taggable,it seems that the plugin can not work at all

that ‘sentence’ is baking my noodle after 20 hours awake… you’re not a
lawyer are you?

anyway, i have had the plugin working since pre 1.1 using edge, with
1.1, and
now back on edge

:through and :polymorphic are 1.1 are they not?

your actual error message may trigger a helpful answer since i had a
few
before i grokked what was going on (errors, not drinks)