Integration test won't run

Im trying to write and run integration tests in my app, but they keep
failing with an error like “uninitialized constant IntegrationTest”
secificly:

/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/
active_support/dependencies.rb:123:in `const_missing’: uninitialized
constant IntegrationTest (NameError)

I tried creating a fresh rails app and was able to run an integration
test from there. I also tried updating to edge with rake rails:edge.
In case the problem was computer specific i tried on my server (as
opposed to my macbook)
there i get:

rake test:integration
(in /home/httpd/anacapamarine.com/htdocs/oncourse_development)
/usr/bin/ruby18 -Ilib:test “/usr/lib64/ruby/gems/1.8/gems/rake-0.7.1/
lib/rake/rake_test_loader.rb” “test/integration/request_part_test.rb”
/usr/lib64/ruby/site_ruby/1.8/rubygems/custom_require.rb:99: [BUG]
Segmentation fault
ruby 1.8.4 (2006-02-24) [x86_64-linux]

Im totally stumped and would appreciate any help or suggstions.

Thanks,

Michael Fairchild

UCLA Particle Beam Physics Lab

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs