# Install rails3 --pre on snow leopard w ruby 1.8.7 -- memcache\_client gem problems

**URL:** <https://www.ruby-forum.com/t/install-rails3-pre-on-snow-leopard-w-ruby-1-8-7-memcache-client-gem-problems/184930>\
**Category:** Rails\
**Created:** [March 10, 2010, 3:31pm UTC](https://www.ruby-forum.com/t/install-rails3-pre-on-snow-leopard-w-ruby-1-8-7-memcache-client-gem-problems/184930 "2010-03-10T15:31:09Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![benissimo](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/b/7993a0/32.png) [@benissimo](https://www.ruby-forum.com/u/benissimo)\
**Post date:** [March 10, 2010, 3:31pm UTC](https://www.ruby-forum.com/t/install-rails3-pre-on-snow-leopard-w-ruby-1-8-7-memcache-client-gem-problems/184930/1 "2010-03-10T15:31:09Z")

</div>

Hello,

Following the indications listed here:

> **[Rails 3.0: Beta release](https://rubyonrails.org/2010/2/5/rails-3-0-beta-release)**
>
> You thought we were never going to get to this day, didn’t you? Ye of little faith. Because here is the first real, public release of Rails 3.0 in the form of a beta package that we’ve toiled long and hard over.It’s surely not perfect yet, but we...

in other words:  
sudo gem install tzinfo builder memcache-client rack rack-test rack-  
mount erubis mail text-format thor bundler i18n  
sudo gem install rails --pre

The first line installed gems without complaint. When I tried the  
second (sudo gem install rails --pre), it complains:  
ERROR: Error installing rails:  
activesupport requires memcache-client (~\> 1.7.5, runtime)

However:  
gem list --local | grep memc  
memcache-client (1.8.0)

So I checked and, from irb:

> > require ‘memcache’  
> > [memcache-client] Could not load SystemTimer gem, falling back to  
> > Ruby’s slower/unsafe timeout library: no such file to load –  
> > system\_timer

OK so I added that:  
sudo gem install system\_timer

And now from irb it seems OK:

> > require ‘memcache’  
> > =\> true  
> > MemCache::VERSION  
> > =\> “1.8.0”

But install of rails --pre still gives no joy:  
sudo gem install rails --pre  
ERROR: Error installing rails:  
activesupport requires memcache-client (~\> 1.7.5, runtime)

Any ideas?

Thanks,  
Ben

---

<div class="post-metadata">

**Author:** ![benissimo](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/b/7993a0/32.png) [@benissimo](https://www.ruby-forum.com/u/benissimo)\
**Post date:** [March 14, 2010, 2:57pm UTC](https://www.ruby-forum.com/t/install-rails3-pre-on-snow-leopard-w-ruby-1-8-7-memcache-client-gem-problems/184930/2 "2010-03-14T14:57:48Z")

</div>

> ```
> activesupport requiresmemcache-client(~> 1.7.5, runtime)
> 
> ```

Are you using jruby by chance?  
Have a look at `gem env`  
If it shows “RUBYGEMS VERSION: 1.3.3” and a gem path involving Jruby  
you’ll run into trouble.

I just dusted off my old ubuntu box and started installing rails 3 and  
ran into this. If it is Jruby, clean up your paths to use MRI or maybe  
setup RVM(Ruby Version Manager).

---

<div class="post-metadata">

**Author:** ![benissimo](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/b/7993a0/32.png) [@benissimo](https://www.ruby-forum.com/u/benissimo)\
**Post date:** [March 14, 2010, 9:44pm UTC](https://www.ruby-forum.com/t/install-rails3-pre-on-snow-leopard-w-ruby-1-8-7-memcache-client-gem-problems/184930/3 "2010-03-14T21:44:34Z")

</div>

No this was regular (not j-) ruby, 1.8.7.  
I think my problem was related to rubygems, at the time I still had  
1.3.5.

Later I installed rvm and, again using ruby 1.8.7, I had more luck  
doing a fresh start by first updating rubygems to 1.3.6 and then  
running only gem install rails --pre, which automatically grabbed all  
the gems needed. This way it grabbed memcache\_client 1.7.8 (not 1.8.0)  
and the whole thing worked without a hitch.

So I’d replace the advice listed on the guides with:

1. update rubygems to 1.3.6 (gem update --system #or whatever  
equivalent you need to do so)
2. then do: gem install rails --pre

With ruby 1.8.7 on snow leopard, that’s all it needs.
