Image don't show up when i run my Rails with webrick server

can yah help me, i need to fix this…

Kenji wrote:

can yah help me, i need to fix this…

I think we need a bit more information to be able to help you… where
are the images? what code is supposed to show it? if you view the
source of the html file, is there a link to the picture in it…

cheers
mohit

Mohit S. wrote:

Kenji wrote:

can yah help me, i need to fix this…

I think we need a bit more information to be able to help you… where
are the images? what code is supposed to show it? if you view the
source of the html file, is there a link to the picture in it…

cheers
mohit

I create a rhtml file in dreamweaver where i include images, it was in
the same folder of that RHTML file i made…

this are the error

Routing error

Recognition failed for “/index.jpg”

Kenji wrote:

source of the html file, is there a link to the picture in it…
Routing error

Recognition failed for “/index.jpg”

A couple of things may help you get started:

  1. By default, images are supposed to go into the “public/images” under
    your application’s root directory. When rhtml files are processed, that
    will be where they will search for the images first. If you place the
    images in another directory, your code will need to change.
  2. If you do a view source in your browser on the page that is
    generated, is there any reference to the image files? Are the image
    files in that directory?

Can you paste the relevant portion of your rhtml file?
Cheers
Mohit.

Thanks, i already figured it out… im just new in RoR so i havent read
it about the public folder… thanks anyway dude. it was nice of you
helping ne…

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs