# I cannot install Rails 3.0 on my OS X

**URL:** <https://www.ruby-forum.com/t/i-cannot-install-rails-3-0-on-my-os-x/188680>\
**Category:** Rails\
**Created:** [May 16, 2010, 9:07am UTC](https://www.ruby-forum.com/t/i-cannot-install-rails-3-0-on-my-os-x/188680 "2010-05-16T09:07:06Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![ssk](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/s/82dd89/32.png) [@ssk](https://www.ruby-forum.com/u/ssk)\
**Post date:** [May 16, 2010, 9:07am UTC](https://www.ruby-forum.com/t/i-cannot-install-rails-3-0-on-my-os-x/188680/1 "2010-05-16T09:07:06Z")

</div>

Hi,

I’ve upgraded ruby to 1.8.7.  
But when I tried to install rails 3.0, it said that I need ruby 1.8.7 or  
higher.

ruby-1.8.7-p248$ ruby -v  
ruby 1.8.7 (2009-12-24 patchlevel 248) [i686-darwin9.8.0]  
ruby-1.8.7-p248$ sudo gem install rails --pre  
ERROR: Error installing rails:  
activesupport requires Ruby version \>= 1.8.7.

What should I do?

Sam

---

<div class="post-metadata">

**Author:** ![ssk](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/s/82dd89/32.png) [@ssk](https://www.ruby-forum.com/u/ssk)\
**Post date:** [May 16, 2010, 10:57am UTC](https://www.ruby-forum.com/t/i-cannot-install-rails-3-0-on-my-os-x/188680/2 "2010-05-16T10:57:03Z")

</div>

Try installing RVM and though it installing Ruby 1.9.1 or 1.9.2  
Ruby 1.9.2 is recommended as of this moment.  
Works for me … although I have some issues on the latter steps.

---

<div class="post-metadata">

**Author:** ![ssk](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/s/82dd89/32.png) [@ssk](https://www.ruby-forum.com/u/ssk)\
**Post date:** [May 16, 2010, 12:11pm UTC](https://www.ruby-forum.com/t/i-cannot-install-rails-3-0-on-my-os-x/188680/3 "2010-05-16T12:11:44Z")

</div>

It might be possible that you have two versions of ruby and two  
versions of rubygems. When you run the application the gem installer  
seems to get the path of the old environment. Try gem env or sudo gem  
env and see the ruby version and ge path.

When the problem will be solved, I suggest to keep a standard ruby  
installation in your Mac and use rvm to install other version. I  
prefer to leave the current system version of Ruby, then I install rvm  
and I load the ruby version that I want, for instance I have installed  
ree, jruy, MRI 1.8.7 and 1.9.1.
