# I am facing problem when i am running my rails app

**URL:** <https://www.ruby-forum.com/t/i-am-facing-problem-when-i-am-running-my-rails-app/155191>\
**Category:** Rails\
**Created:** [December 9, 2008, 6:07am UTC](https://www.ruby-forum.com/t/i-am-facing-problem-when-i-am-running-my-rails-app/155191 "2008-12-09T06:07:38Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![nike](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/n/dbc845/32.png) [@nike](https://www.ruby-forum.com/u/nike)\
**Post date:** [December 9, 2008, 6:07am UTC](https://www.ruby-forum.com/t/i-am-facing-problem-when-i-am-running-my-rails-app/155191/1 "2008-12-09T06:07:38Z")

</div>

hi have upgraded my version from 2.0.2 to 2.2.2.but the application  
which i have created from rails 2.0.2 is not getting started.

Throwing

ruby script/server  
/usr/local/lib/site\_ruby/1.8/rubygems.rb:149:in `activate': can't activate activesupport (= 2.2.2, runtime), already activated activesupport-2.0.2 (Gem::Exception) from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:35:in`require’  
from  
/usr/lib/ruby/gems/1.8/gems/activesupport-2.0.2/lib/active\_support.rb:28  
from /usr/local/lib/site\_ruby/1.8/rubygems/custom\_require.rb:31:in  
`gem_original_require' from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in`require’  
from /usr/lib/ruby/gems/1.8/gems/rails-2.0.2/lib/commands/server.rb:1  
from /usr/local/lib/site\_ruby/1.8/rubygems/custom\_require.rb:31:in  
`gem_original_require' from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:31:in`require’  
from script/server:3

---

<div class="post-metadata">

**Author:** ![nike](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/n/dbc845/32.png) [@nike](https://www.ruby-forum.com/u/nike)\
**Post date:** [December 9, 2008, 9:48am UTC](https://www.ruby-forum.com/t/i-am-facing-problem-when-i-am-running-my-rails-app/155191/2 "2008-12-09T09:48:17Z")

</div>

On Dec 9, 5:07 am, Nike M. [removed\_email\_address@domain.invalid](mailto:removed_email_address@domain.invalid) wrote:

> hi have upgraded my version from 2.0.2 to 2.2.2.but the application  
> which i have created from rails 2.0.2 is not getting started.

Something is explicitly requiring another version of activesupport  
(for example I think old versions of will\_paginate did this).

Fred

---

<div class="post-metadata">

**Author:** ![nike](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/n/dbc845/32.png) [@nike](https://www.ruby-forum.com/u/nike)\
**Post date:** [December 9, 2008, 12:42pm UTC](https://www.ruby-forum.com/t/i-am-facing-problem-when-i-am-running-my-rails-app/155191/3 "2008-12-09T12:42:36Z")

</div>

hi have upgraded my version from 2.0.2 to 2.2.2.but the application  
which i have created from rails 2.0.2 is not getting started.

REPLY:

Hi,  
you have upgraded rails 2.2.2. right! have you install gem rails -  
v=2.2.2. if not install and check it. then you can get the exact  
result.

Thanks,  
Karthie

---

<div class="post-metadata">

**Author:** ![nike](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/n/dbc845/32.png) [@nike](https://www.ruby-forum.com/u/nike)\
**Post date:** [December 9, 2008, 12:43pm UTC](https://www.ruby-forum.com/t/i-am-facing-problem-when-i-am-running-my-rails-app/155191/4 "2008-12-09T12:43:12Z")

</div>

hi have upgraded my version from 2.0.2 to 2.2.2.but the application  
which i have created from rails 2.0.2 is not getting started.

Hi,  
You have upgraded rails 2.2.2. right! have u “install gem -v=2.2.2  
rails” after installing rails 2.2.2. if not install it and check it.  
then you can get the exact result for the application which u did in  
rails 2.0.2.

Thanks,  
Karthie
