# How to upgrade ruby to a specific version

**URL:** <https://www.ruby-forum.com/t/how-to-upgrade-ruby-to-a-specific-version/171632>\
**Category:** Ruby\
**Created:** [July 6, 2009, 9:27pm UTC](https://www.ruby-forum.com/t/how-to-upgrade-ruby-to-a-specific-version/171632 "2009-07-06T21:27:31Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![tharrisx](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/t/e19adc/32.png) [@tharrisx](https://www.ruby-forum.com/u/tharrisx)\
**Post date:** [July 6, 2009, 9:27pm UTC](https://www.ruby-forum.com/t/how-to-upgrade-ruby-to-a-specific-version/171632/1 "2009-07-06T21:27:31Z")

</div>

Hi there,

sorry for the n00b question:

What’s the correct linux command for upgrading ruby to a specific  
version? (Ruby 1.8.6-p369 is needed.)

Btw, it’s this security issue that leads me to it:  
[http://www.ruby-lang.org/en/news/2009/06/09/dos-vulnerability-in-bigdecimal/](http://www.ruby-lang.org/en/news/2009/06/09/dos-vulnerability-in-bigdecimal/)

Thanks a lot!  
Tom

---

<div class="post-metadata">

**Author:** ![tharrisx](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/t/e19adc/32.png) [@tharrisx](https://www.ruby-forum.com/u/tharrisx)\
**Post date:** [July 7, 2009, 12:15pm UTC](https://www.ruby-forum.com/t/how-to-upgrade-ruby-to-a-specific-version/171632/2 "2009-07-07T12:15:42Z")

</div>

Anybody…?

(I couldn’t find the answer using search engines…)

---

<div class="post-metadata">

**Author:** ![tharrisx](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/t/e19adc/32.png) [@tharrisx](https://www.ruby-forum.com/u/tharrisx)\
**Post date:** [July 7, 2009, 1:21pm UTC](https://www.ruby-forum.com/t/how-to-upgrade-ruby-to-a-specific-version/171632/3 "2009-07-07T13:21:22Z")

</div>

On Monday 06 July 2009, Tom Ha wrote:

> |  
> |Thanks a lot!  
> |Tom

That depends on which linux distribution you use. Without knowing that,  
we  
can’t give you an answer. For example, on Gentoo it is:

sudo emerge “=ruby-1.8.6\_p369”

but on Debian, or Mandriva or Ubuntu, or… the command would be  
completely  
different.

If you want an answer, please, tell us which distribution are you using.

Stefano

---

<div class="post-metadata">

**Author:** ![tharrisx](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/t/e19adc/32.png) [@tharrisx](https://www.ruby-forum.com/u/tharrisx)\
**Post date:** [July 7, 2009, 5:52pm UTC](https://www.ruby-forum.com/t/how-to-upgrade-ruby-to-a-specific-version/171632/4 "2009-07-07T17:52:36Z")

</div>

On Tuesday 07 July 2009 04:55:01 Tom Ha wrote:

> Sorry, I didn’t know that…
> 
> I actually use Ubuntu (9.04).

And while Ubuntu has confirmed the bug, and it has been fixed in Debian  
unstable, it still remains an open issue:

> **[Bug #385436 “DoS vulnerability in BigDecimal Ruby Library” : Bugs : ruby1.8...](https://bugs.launchpad.net/ubuntu/+source/ruby1.8/+bug/385436)**
>
> A denial of service (DoS) vulnerability was found on the BigDecimal standard library of Ruby. Conversion from BigDecimal objects into Float numbers had a problem which enables attackers to effectively cause segmentation faults.
> 
> Refer to the...

Best bet is to download the source and compile it yourself at this  
point.  
Link:

ftp://ruby-lang.org/pub/ruby/ruby-1.8.6-p369.tar.gz

---

<div class="post-metadata">

**Author:** ![tharrisx](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/t/e19adc/32.png) [@tharrisx](https://www.ruby-forum.com/u/tharrisx)\
**Post date:** [July 7, 2009, 1:54pm UTC](https://www.ruby-forum.com/t/how-to-upgrade-ruby-to-a-specific-version/171632/5 "2009-07-07T13:54:58Z")

</div>

Sorry, I didn’t know that…

I actually use Ubuntu (9.04).

---

<div class="post-metadata">

**Author:** ![tharrisx](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/t/e19adc/32.png) [@tharrisx](https://www.ruby-forum.com/u/tharrisx)\
**Post date:** [July 7, 2009, 6:12pm UTC](https://www.ruby-forum.com/t/how-to-upgrade-ruby-to-a-specific-version/171632/6 "2009-07-07T18:12:59Z")

</div>

Thanks for your answer.

The thing is, I’m a n00b in Linux as well (and therefore not used to  
compile stuff, etc.).

Is it really not possible to update Ruby on my Ubuntu machine to a  
specific patch level, simply using a terminal command?

I need to upgrade to “ruby 1.8.6-p369” (version 1.9 is not yet  
sufficiently supported).

Thanks for any help with this!

---

<div class="post-metadata">

**Author:** ![tharrisx](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/t/e19adc/32.png) [@tharrisx](https://www.ruby-forum.com/u/tharrisx)\
**Post date:** [July 7, 2009, 6:47pm UTC](https://www.ruby-forum.com/t/how-to-upgrade-ruby-to-a-specific-version/171632/7 "2009-07-07T18:47:34Z")

</div>

On Tue, Jul 7, 2009 at 12:13 PM, Tom Ha[removed\_email\_address@domain.invalid](mailto:removed_email_address@domain.invalid) wrote:

> Thanks for your answer.
> 
> The thing is, I’m a n00b in Linux as well (and therefore not used to  
> compile stuff, etc.).
> 
> Is it really not possible to update Ruby on my Ubuntu machine to a  
> specific patch level, simply using a terminal command?

Assuming you mean via apt-get or it’s brethren, no. You’re limited to  
what the Ubuntu/Debian maintainer has decided to package.

And I’m pretty sure that for 9.04 you’re only going to find 1.8.7  
packages anyway.

> I need to upgrade to “ruby 1.8.6-p369” (version 1.9 is not yet  
> sufficiently supported).

The only way to get control at this level is to install from source.

It’s really not that hard, google will provide lots of help.

On the other hand, I’m not sure that the bigdecimal DOS bug is really  
that much of an exposure. Unless I misunderstood him, Charlie Nutter  
(of JRuby fame) posted somewhere that Java has had the same issue for  
quite some time.

–  
Rick DeNatale

Blog: [http://talklikeaduck.denhaven2.com/](http://talklikeaduck.denhaven2.com/)  
Twitter: [http://twitter.com/RickDeNatale](http://twitter.com/RickDeNatale)  
WWR: [http://www.workingwithrails.com/person/9021-rick-denatale](http://www.workingwithrails.com/person/9021-rick-denatale)  
LinkedIn: [http://www.linkedin.com/in/rickdenatale](http://www.linkedin.com/in/rickdenatale)

---

<div class="post-metadata">

**Author:** ![tharrisx](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/t/e19adc/32.png) [@tharrisx](https://www.ruby-forum.com/u/tharrisx)\
**Post date:** [July 8, 2009, 7:07am UTC](https://www.ruby-forum.com/t/how-to-upgrade-ruby-to-a-specific-version/171632/8 "2009-07-08T07:07:44Z")

</div>

On Tue, Jul 7, 2009 at 11:46 AM, Rick DeNatale[removed\_email\_address@domain.invalid](mailto:removed_email_address@domain.invalid)  
wrote:

> On the other hand, I’m not sure that the bigdecimal DOS bug is really  
> that much of an exposure. Â Unless I misunderstood him, Charlie Nutter  
> (of JRuby fame) posted somewhere that Java has had the same issue for  
> quite some time.

It does…and I patched around one vector for it, but the fact that  
it’s been possible to have this same sort of “infinite execution DOS”  
on the JVM makes me think it’s not that big a deal.

- Charlie

---

<div class="post-metadata">

**Author:** ![tharrisx](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/t/e19adc/32.png) [@tharrisx](https://www.ruby-forum.com/u/tharrisx)\
**Post date:** [July 7, 2009, 7:21pm UTC](https://www.ruby-forum.com/t/how-to-upgrade-ruby-to-a-specific-version/171632/9 "2009-07-07T19:21:35Z")

</div>

Thanks!
