Help Installing Mongrel - Broken Gems?

Hello all,
I’m trying to get a basic setup with Apache on Ubuntu with Mongrel. I
followed a tutorial that suggested installing apache, which I did. Next,
I ran the following command:

sudo gem install daemons gem_plugin mongrel mongrel_cluster
–include-dependencies

Afterward, I got the following code explosion, which
I seem to be getting every time I try to install a gem.

Bulk updating Gem source index for: http://gems.rubyforge.org
Successfully installed daemons-1.0.2
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:in
gem_original_requ ire': no such file to load -- rdoc/rdoc (LoadError) from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:27:inrequ ire’
from /usr/local/lib/site_ruby/1.8/rubygems/doc_manager.rb:71:in
load_rd oc' from /usr/local/lib/site_ruby/1.8/rubygems/doc_manager.rb:41:ingenerat e_ri’
from
/usr/local/lib/site_ruby/1.8/rubygems/gem_commands.rb:283:in execu te' from /usr/local/lib/site_ruby/1.8/rubygems/gem_commands.rb:282:inexecu te’
from
/usr/local/lib/site_ruby/1.8/rubygems/gem_commands.rb:220:in execu te' from /usr/local/lib/site_ruby/1.8/rubygems/command.rb:69:ininvoke’
from /usr/local/lib/site_ruby/1.8/rubygems/cmd_manager.rb:117:in
proces s_args' from /usr/local/lib/site_ruby/1.8/rubygems/cmd_manager.rb:88:inrun’
from /usr/local/lib/site_ruby/1.8/rubygems/gem_runner.rb:29:in
`run’
from /usr/bin/gem:23

Any idea what might be causing this? My suspicion is that
gems is broken somehow, but I have no idea how to fix it.

Will


How low will we go? Check out Yahoo! MessengerÂ?s low PC-to-Phone call
rates.

On Mon, 9 Oct 2006 16:54:51 -0700 (PDT)
Will G. [email protected] wrote:

Hello all,
I’m trying to get a basic setup with Apache on Ubuntu with Mongrel. I followed a tutorial that suggested installing apache, which I did. Next, I ran the following command:

http://mongrel.rubyforge.org/docs/debian-sarge.html

and

http://www.jkraemer.net/2006/7/7/mongrel-apache-and-rails-on-debian-sarge

Will set you straight, and should work or be a good guide to Ubuntu as
well. If not let me know.


Zed A. Shaw, MUDCRAP-CE Master Black Belt Sifu


http://mongrel.rubyforge.org/
http://www.lingr.com/room/3yXhqKbfPy8 – Come get help.

Well, I was able to confirm that Apache is working on my system. I
created a simple rails app called test and placed it on my desktop. I
created the config files, but I knew I had to set the user (so that it
could access the app on my desktop). However, the file
/etc/default/mongrel isn’t on my system (or it was put somewhere else).

I’m a bit of a noob on the whole Linux/Apache/Ruby thing. I ran the
command:
sudo /etc/init.d/mongrel start

and mongrel apparently started. However, when I run a portscan, I’m not
seeing that port open in the list. Is there any way I can test first to
make sure that I’ve got mongrel set up correctly before I get all
tangled up in Apache?

Thanks,
Will

“Zed A. Shaw” [email protected] wrote:
On Mon, 9 Oct 2006 16:54:51 -0700 (PDT)
Will G. wrote:

Hello all,
I’m trying to get a basic setup with Apache on Ubuntu with Mongrel. I followed a tutorial that suggested installing apache, which I did. Next, I ran the following command:

http://mongrel.rubyforge.org/docs/debian-sarge.html

and

http://www.jkraemer.net/2006/7/7/mongrel-apache-and-rails-on-debian-sarge

Will set you straight, and should work or be a good guide to Ubuntu as
well. If not let me know.


Zed A. Shaw, MUDCRAP-CE Master Black Belt Sifu


http://mongrel.rubyforge.org/
http://www.lingr.com/room/3yXhqKbfPy8 – Come get help.


Do you Yahoo!?
Get on board. You’re invited to try the new Yahoo! Mail.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs