Hello world

The apache config file is either /etc/apache2/apache.conf or /etc/
apache2/httpd.conf. You might have more virtual host files in /etc/
apache2/sites-available/sitename (which then must be enabled). The
file that you added lines to is just the init script that starts and
stops apache.

-Kyle

On Apr 26, 10:25 pm, Mickey C. [email protected]

Thanks for the help Kyle. That fixed the problem I was having. I feel
like I’m really close, but now I’m seeing an error 500 with the text:

We’re sorry, but something went wrong.

We’ve been notified about this issue and we’ll take a look at it
shortly.

I feel like this is a problem with the routes.rb, but I’m not sure about
that. The only change I made to the routes.rb file is I uncommented the
line:

map.root :controller => “welcome”

I have a controller: app/controllers/welcome_controller.rb and
a view: app/views/welcome/index.html.erb

Does anyone see something obvious that I’m doing wrong? Do I need to
configure MySQL with a user / pass for rails? Thanks again for the
help.

Mickey

I have my production environment up and running now. The problem was
that I didn’t have MySQL configured properly. (I figured for a “hello
world” app that didn’t require a database, that I didn’t have to have
the database configured). But the question I have now is how do I
encrypt my MySQL password in the config/database.yml file? I can
actually view my credentials at:

http://xxx.xxx.xxx.xxx/example.com/app/config/database.yml

So anyone can view my password right now! It’s a dummy password for
now, but still, at some point it’s going to be a big deal that anyone
can view my MySQL user credentials. What are my options for securing
those credentials? Thanks in advance.

Mickey

try it with mongrel and make sure it works [?]

On Tue, Apr 29, 2008 at 6:16 PM, Mickey C.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs