# Freezing Rails 2.3.4 to application

**URL:** <https://www.ruby-forum.com/t/freezing-rails-2-3-4-to-application/175273>\
**Category:** Rails\
**Created:** [September 10, 2009, 1:26pm UTC](https://www.ruby-forum.com/t/freezing-rails-2-3-4-to-application/175273 "2009-09-10T13:26:30Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![neetal](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/n/ba8739/32.png) [@neetal](https://www.ruby-forum.com/u/neetal)\
**Post date:** [September 10, 2009, 1:26pm UTC](https://www.ruby-forum.com/t/freezing-rails-2-3-4-to-application/175273/1 "2009-09-10T13:26:30Z")

</div>

Hi Everyone

I am trying to update my Rails 2.1.2 to Rails 2.3.4.

I have upgraded to Rails 2.3.4 and freezed the Rails 2.3.4 to my  
application. But when am trying to run the server , am getting this  
error

config.gem: Unpacked gem ClothRed in vendor/gems has no specification  
file. Run  
‘rake gems:refresh\_specs’ to fix this.  
config.gem: Unpacked gem ClothRed in vendor/gems not in a versioned  
directory. G  
iving up.  
config.gem: Unpacked gem mime-types-1.15 in vendor/gems has no  
specification fil  
e. Run ‘rake gems:refresh\_specs’ to fix this.  
C:/Ruby\_App\_Bckup/PVC\_Rails\_2.3.4/PVC/vendor/rails/activesupport/lib/active\_supp  
ort/core\_ext/module/aliasing.rb:33:in `alias_method': undefined method`pick\_tem  
plate’ for class `ActionView::TemplateFinder' (NameError) from C:/Ruby_App_Bckup/PVC_Rails_2.3.4/PVC/vendor/rails/activesupport/li b/active_support/core_ext/module/aliasing.rb:33:in`alias\_method\_chain’  
from  
C:/Ruby\_App\_Bckup/PVC\_Rails\_2.3.4/PVC/vendor/plugins/active\_scaffol  
d/lib/extensions/generic\_view\_paths.rb:35  
from  
c:/ruby/lib/ruby/site\_ruby/1.8/rubygems/custom\_require.rb:31:in `ge m_original_require' from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in`re  
quire’  
from  
C:/Ruby\_App\_Bckup/PVC\_Rails\_2.3.4/PVC/vendor/rails/activesupport/li  
b/active\_support/dependencies.rb:156:in `require' from C:/Ruby_App_Bckup/PVC_Rails_2.3.4/PVC/vendor/rails/activesupport/li b/active_support/dependencies.rb:521:in`new\_constants\_in’  
from  
C:/Ruby\_App\_Bckup/PVC\_Rails\_2.3.4/PVC/vendor/rails/activesupport/li  
b/active\_support/dependencies.rb:156:in `require' from C:/Ruby_App_Bckup/PVC_Rails_2.3.4/PVC/vendor/plugins/active_scaffol d/environment.rb:63 ... 25 levels... from C:/Ruby_App_Bckup/PVC_Rails_2.3.4/PVC/vendor/rails/railties/lib/com mands/server.rb:84 from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in`ge  
m\_original\_require’  
from  
c:/ruby/lib/ruby/site\_ruby/1.8/rubygems/custom\_require.rb:31:in `re  
quire’  
from script/server:3

Am i missing something , do i have to do something else also.

Please Advice !  
Thanks in Advance.

Neetal

---

<div class="post-metadata">

**Author:** ![neetal](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/n/ba8739/32.png) [@neetal](https://www.ruby-forum.com/u/neetal)\
**Post date:** [September 10, 2009, 9:08pm UTC](https://www.ruby-forum.com/t/freezing-rails-2-3-4-to-application/175273/2 "2009-09-10T21:08:11Z")

</div>

The first couple warnings are related to the 2.1 era gem freezer,  
which didn’t unpack gemspecs. The rake task listed in the error should  
fix that.

The other error appears to be from activescaffold trying to override  
part of ActionView; I’d guess that you’ll need to upgrade  
activescaffold.

–Matt J.

On Sep 10, 7:26 am, Neetal S. [removed\_email\_address@domain.invalid](mailto:removed_email_address@domain.invalid)

---

<div class="post-metadata">

**Author:** ![neetal](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/n/ba8739/32.png) [@neetal](https://www.ruby-forum.com/u/neetal)\
**Post date:** [September 11, 2009, 8:55am UTC](https://www.ruby-forum.com/t/freezing-rails-2-3-4-to-application/175273/3 "2009-09-11T08:55:56Z")

</div>

Thanks much Matt…

That worked for me , now am running in to some different issue.

When i tried to run the server it says

===========================================================================================  
c:/ruby/lib/ruby/gems/1.8/gems/acts\_as\_ferret-0.4.4/lib/acts\_as\_ferret.rb:267:  
w  
arning: parenthesize argument(s) for future version  
c:/ruby/lib/ruby/site\_ruby/1.8/rubygems/custom\_require.rb:31:in  
`gem_original_re quire': no such file to load -- ferret_ext (MissingSourceFile) from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in`re  
quire’  
from  
C:/Ruby\_App\_Bckup/PVC\_Rails\_2.3.4/PVC/vendor/rails/activesupport/li  
b/active\_support/dependencies.rb:156:in `require' from C:/Ruby_App_Bckup/PVC_Rails_2.3.4/PVC/vendor/rails/activesupport/li b/active_support/dependencies.rb:521:in`new\_constants\_in’  
from  
C:/Ruby\_App\_Bckup/PVC\_Rails\_2.3.4/PVC/vendor/rails/activesupport/li  
b/active\_support/dependencies.rb:156:in `require' from C:/Ruby_App_Bckup/PVC_Rails_2.3.4/PVC/vendor/gems/ferret-0.11.6/lib /ferret.rb:25 from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in`ge  
m\_original\_require’  
from  
c:/ruby/lib/ruby/site\_ruby/1.8/rubygems/custom\_require.rb:36:in `re quire' from C:/Ruby_App_Bckup/PVC_Rails_2.3.4/PVC/vendor/rails/activesupport/li b/active_support/dependencies.rb:156:in`require’  
… 14 levels…  
from  
C:/Ruby\_App\_Bckup/PVC\_Rails\_2.3.4/PVC/vendor/rails/railties/lib/com  
mands/server.rb:84  
from  
c:/ruby/lib/ruby/site\_ruby/1.8/rubygems/custom\_require.rb:31:in `ge m_original_require' from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in`re  
quire’  
from script/server:3

===================================================================================

But i do have  
1\> ferret (0.11.5) gem installed and acts\_as\_ferret (0.4.4, 0.3.1) gem  
installed.  
2\> I have already added these lines to environment.rb  
i\>require ‘acts\_as\_ferret’  
ii\>config.gem ‘ferret’

but still facing the problem, no clue which version of ferret i should  
install.

Could you please suggest something.

Thanks and Advance !!

Neetal

---

<div class="post-metadata">

**Author:** ![neetal](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/n/ba8739/32.png) [@neetal](https://www.ruby-forum.com/u/neetal)\
**Post date:** [September 11, 2009, 7:32pm UTC](https://www.ruby-forum.com/t/freezing-rails-2-3-4-to-application/175273/4 "2009-09-11T19:32:52Z")

</div>

The error is looking for ferret\_ext, which is actually a DLL created  
by the gem installer when the ferret gem is installed. My guess is  
that you’re missing the compiler toolchain needed to build it on  
Windows; you may want to find a binary version of the gem. This thread  
may be helpful:

[http://groups.google.com/group/rubyonrails-talk/browse\_thread/thread/02def3b3133bb0ab/e702ed8307fc1837?lnk=raot](http://groups.google.com/group/rubyonrails-talk/browse_thread/thread/02def3b3133bb0ab/e702ed8307fc1837?lnk=raot)

–Matt J.

On Sep 11, 2:55 am, Neetal S. [removed\_email\_address@domain.invalid](mailto:removed_email_address@domain.invalid)
