Ferret for professionals

On Wed, Sep 05, 2007 at 12:28:53PM +0200, Igor K. wrote:

can’t see what’s wrong with the screenshot (besides the missing images
for yes/no).

did you check the index contents?

What do you mean?

please check another attachment, why i can see only id field?

ah, of course. aaf by default only stores the id in the index, the rest
of the data is just indexed (so records can be found, but you cannot
retrieve their original contents from the index). use something like

acts_as_ferret :fields => {
:name => { :store => :yes },
:body => { :store => :yes }
}

then you’ll see the data in ferret-browser.

Jens


Jens Krämer
webit! Gesellschaft für neue Medien mbH
Schnorrstraße 76 | 01069 Dresden
Telefon +49 351 46766-0 | Telefax +49 351 46766-66
[email protected] | www.webit.de

Amtsgericht Dresden | HRB 15422
GF Sven Haubold, Hagen Malessa

Igor, hi!

Seems I’ve got the same problem. Have you finally solved it?

My working environment is:

  • WinXP Pro SP2 rus
  • NetBeans 6.1
  • MySQL 5.0.45 (with all possible encoding params set to UTF-8)
  • RoR 2.0.2 (database.yml has ‘encoding: utf8’ string at proper places)
  • ferret 0.11.5 (i.e. newest)
  • acts_as_ferret (newest stable version installed inside of my RoR
    project).

My code example: http://pastie.caboo.se/194268

When I point my browser http://localhost:3000/people I get 2 persons in
the list while it’s expected to have zero.

I also tried to experiment with all those things mentioned above in this
thread (locales, enviroment.rb and so on) - nothing positive.

My friend who has Mac + Leopard OS has just tested my code - on his
machine the code worked as expected. So I think it is an OS-dependent
issue of ferret or aaf…

Ohhhh :),

it is not working anyway, please check attachment.

in console as you can see i searching by symbol that one word in
database starts.

i don’t know what to do?

locale in system - russian

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs