Fcgi errors when starting rails with lighttpd server on Mac

When I do a script/server, lighttpd boots, successfully, even, but
displays the following message:

/usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:123:in
const_missing': uninitialized constant RailsFCGIHandler (NameError) from /usr/lib/ruby/gems/1.8/gems/activesupport-1.3.1/lib/active_support/dependencies.rb:131:inconst_missing’
from /Users/alpaca/rails/test/public/dispatch.fcgi:24

I Googled said message, and found that the error is allegedly caused by
FastCGI not being installed, but I specifically went back and made sure
that fcgi, its ruby hook, and the appropriate gem were all installed,
all inside /usr/local.

I’m running Mac OS X 10.4.8 with a PowerPC processor, latest version of
everything except mysql, which is 5.0.19 and shouldn’t impact anything
anyway.

Any help would be greatly appreciated.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs