Error with installing rails/gems on ubuntu-dapper


#1

I am getting an error when trying to install rails on dapper. It looks
like it partially installed something. Mainly the issue seems to be
with ‘gems’?
I am using:
ruby-1.8.4
gems 0.8.11

Is this bad?

bbrown@england:~/rubygems-0.8.11$ sudo gem install rails
–include-dependencies
Attempting local installation of ‘rails’
Local gem file not found: rails*.gem
Attempting remote installation of ‘rails’
Updating Gem source index for: http://gems.rubyforge.org
Updating Gem source index for: http://gems.rubyforge.org
Updating Gem source index for: http://gems.rubyforge.org
Updating Gem source index for: http://gems.rubyforge.org
Updating Gem source index for: http://gems.rubyforge.org
Successfully installed rails-1.1.2
Successfully installed rake-0.7.1
Successfully installed activesupport-1.3.1
Successfully installed activerecord-1.14.2
Successfully installed actionpack-1.12.1
Successfully installed actionmailer-1.2.1
Successfully installed actionwebservice-1.1.2
/usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:in
require__': no such file to load -- rdoc/rdoc (LoadError) from /usr/local/lib/site_ruby/1.8/rubygems/custom_require.rb:21:inrequire’
from /usr/local/lib/site_ruby/1.8/rubygems/doc_manager.rb:43:in
generate_rdoc' from /usr/local/lib/site_ruby/1.8/rubygems/gem_commands.rb:215:inexecute’
from
/usr/local/lib/site_ruby/1.8/rubygems/gem_commands.rb:214:in execute' from /usr/local/lib/site_ruby/1.8/rubygems/gem_commands.rb:153:inexecute’
from /usr/local/lib/site_ruby/1.8/rubygems/command.rb:49:in
invoke' from /usr/local/lib/site_ruby/1.8/rubygems/cmd_manager.rb:94:inprocess_args’
from /usr/local/lib/site_ruby/1.8/rubygems/cmd_manager.rb:67:in
run' from /usr/local/lib/site_ruby/1.8/rubygems/gem_runner.rb:13:inrun’
from /usr/bin/gem:17
bbrown@england:~/rubygems-0.8.11$


Berlin B.
(ramaza3 on freenode)
http://www.newspiritcompany.com
also checkout alpha version of botverse:
http://www.newspiritcompany.com:8086/universe_home


#2

El lun, 17-04-2006 a las 14:09 -0400, Berlin B. escribió:

I am getting an error when trying to install rails on dapper. It looks
like it partially installed something. Mainly the issue seems to be
with ‘gems’?
I am using:
ruby-1.8.4
gems 0.8.11

Is this bad?

First do a:

sudo aptitude install rdoc irb


Jonathan Hernández Velasco aka jBilbo
http://jhernandez.gpltarragona.org
Vpte. GPLtarragona ;; http://www.gpltarragona.org
GnuPG key ID: 348EAC17 ;; pgp.mit.edu