Editting dispatch.fcgi in Windows

Hi all,

Many times when I deploy an application to my host from my Windows
development box, things don’t work until I open dispatch.fcgi and save
it
with nano in ssh. This happens whether I deploy manually or with
Capistrano. I understand that Windows based text editters can introduce
bad
carriage returns or something. Does anyone know how to avoid this
problem?
Does anyone else have the same problem?

Any clues are greatly appreciated!!


Terry (TAD) Donaghe
http://www.tadspot.com
http://www.rubynoob.com

Howdy,
If you use an editor such as SciTE, UltraEdit, metapad, or Notepad2
that supports the UNIX format, you should be fine. :slight_smile:

–Jeremy

I downloaded UltraEdit and I think I’ve determined that “Unix” format
means
that the end of line character should just be a LineFeed instead of a
CarriageReturn+LineFeed. UltraEdit also has a Conversion option to let
you
convert from DOS to Unix, and I made a trivial edit, did the conversion
and
saved and at the end of the Cap Deploy I still get the message that
dispatch.fcgi is not an executable file.

I still have to open the file and make a save (I just add a space after
a
comment) in nano in order for dispatch.fcgi to be recognized as an
executable file.

So, even though I’m saving the file in windows as a Unix file, I’m still
forced to fiddle with it before it’ll run up on the server.

Does anyone else running cap with Windows have this problem?

What else can I do to ensure that the file will execute on deploy? It
sucks
having to do the extra steps like that.

On 9/18/06, Jeremy McAnally [email protected] wrote:

Any clues are greatly appreciated!!


Terry (TAD) Donaghe
http://www.tadspot.com
http://www.rubynoob.com


Terry (TAD) Donaghe
http://www.tadspot.com
http://www.rubynoob.com

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs