Easiest rails install for LAMP webserver?

Greetings! Here’s my first nuby question, apologies to all because it’s
probably not /your/ first time hearing one.

I’ve been learning Ruby lately, and would like to start some Rails
development as soon as school’s done. So, in the midst of finals and
term papers and moving out into the world of dial-up, I’d like to get
things set up on a hosted web/shell account, which is already set up
with a LAMP stack [he.com].

I’ve been checking out the links on
but as my server situation seems pretty common, I’m wondering if there’s
an all-in-one deal I can drop in? Otherwise, am I correct that all I
need to start messing around (given Apache/MySQL already running) is
Ruby and the Rails gem? For now, I’m interested in the least
configuration to “hello world”.

thanks much!

Alright, I got ruby, rubygem and perhaps rails installed on my account.

I am able to run a plain Ruby script from my cgi-bin.

I can create a whole mess of folders and files by typing “rails
testrails” in my cgi-bin.

But after that, I can’t get the wonderful behavior described in all the

Going to ‘/cgi-bin/testrails/public/’ gets 404’ed.
When I go to /cgi-bin/testrails/public/index.html, I get the 500 error
defined in the .htaccess file: “Rails application failed to start

Running ./dispatch.cgi straight from the shell leaves the following in

Recognition failed for “”
recognition_failed' /home/natevw/devtemp//lib/ruby/gems/1.8/gems/actionpack-1.12.1/lib/action_controller/routing.rb:478:inrecognize!’

What am I missing?


Changed subject to reflect new developments.

I can run the script/server just fine, “Riding the Rails” shows up on
http://myserver.com:3000, but still nothing via my host’s Apache2.

At least part of the problem must be with paths. I have ruby installed
in ~/devtemp/bin. However, most of the scripts reference “#!/usr/bin/env
ruby” when the path is set to some basic default.

I tried SetEnv PATH /home/natevw/devtemp/bin in the
railstest/public/.htaccess, and tried setting ENV[‘PATH’] ||= ‘’
in an environment.rb file. Still no luck!

How do I set the CGI’s path correctly so that Ruby sees it?

Googling and forum searching, I’m not finding many others installing
Rails into a hosted account on someone else’s server. Surely this is not
the case…?


This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs