# Deployment failing due to invalid rubygems on server

**URL:** <https://www.ruby-forum.com/t/deployment-failing-due-to-invalid-rubygems-on-server/179980>\
**Category:** Deployment\
**Created:** [December 9, 2009, 4:48am UTC](https://www.ruby-forum.com/t/deployment-failing-due-to-invalid-rubygems-on-server/179980 "2009-12-09T04:48:20Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![chrisolsen](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/c/c6cbf5/32.png) [@chrisolsen](https://www.ruby-forum.com/u/chrisolsen)\
**Post date:** [December 9, 2009, 4:48am UTC](https://www.ruby-forum.com/t/deployment-failing-due-to-invalid-rubygems-on-server/179980/1 "2009-12-09T04:48:20Z")

</div>

I am getting the following message when deploying with capistrano.  
However, I do have the latest version (1.3.5) of rubygems installed on  
the server.

> Rails requires RubyGems \>= 1.3.2 (you have 1.3.1). Please `gem update --system` and try again

I have found a few posts regarding this error, but none of the solutions  
have worked for me.

Has anyone seen this before and have a solution?

Thanks for the help.

---

<div class="post-metadata">

**Author:** ![chrisolsen](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/c/c6cbf5/32.png) [@chrisolsen](https://www.ruby-forum.com/u/chrisolsen)\
**Post date:** [December 18, 2009, 5:39pm UTC](https://www.ruby-forum.com/t/deployment-failing-due-to-invalid-rubygems-on-server/179980/2 "2009-12-18T17:39:02Z")

</div>

Chris O. wrote:

> I am getting the following message when deploying with capistrano.  
> However, I do have the latest version (1.3.5) of rubygems installed on  
> the server.
> 
> > Rails requires RubyGems \>= 1.3.2 (you have 1.3.1). Please `gem update --system` and try again
> 
> I have found a few posts regarding this error, but none of the solutions  
> have worked for me.
> 
> Has anyone seen this before and have a solution?
> 
> Thanks for the help.

Maybe the problem is at your end rather than the server end? Make sure  
your local environment has the same gems as the server, and the same  
version of rubygems.

---

<div class="post-metadata">

**Author:** ![chrisolsen](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/c/c6cbf5/32.png) [@chrisolsen](https://www.ruby-forum.com/u/chrisolsen)\
**Post date:** [December 18, 2009, 7:32pm UTC](https://www.ruby-forum.com/t/deployment-failing-due-to-invalid-rubygems-on-server/179980/3 "2009-12-18T19:32:48Z")

</div>

Sorry for the lack of an update. The reason was that I had ruby 1.8 and  
1.9 installed on the system each with own set of gems. The ruby 1.8 had  
the latest version of rubygems while 1.9 had an older version.
