Configure Apache 2.0.55 and FastCGI

I’m installing a Rails App under Apache 2.0.55 with FastCGI.

I have this config under httpd.conf

LoadModule fastcgi_module modules/mod_fastcgi.dll

Alias /fatturails/ “C:/Programmi/Apache
<Directory “C:/Programmi/Apache Group/Apache2/htdocs/fatturails/public”>
AddHandler fastcgi-script .fcgi
Options +ExecCGI
AllowOverride All
Allow from all
Order Allow,deny

FastCgiServer “C:/Programmi/Apache
Group/Apache2/htdocs/fatturails/public/dispatch.fcgi” -processes 1

Then in my .htaccess i have this code

General Apache options

AddHandler fastcgi-script .fcgi

AddHandler cgi-script .cgi

Options +FollowSymLinks +ExecCGI

RewriteRule ^(.*)$ /fatturails/dispatch.fcgi [QSA,L]

When I start Apache all ok, but if I try to open my application I have
this error in errors.log (after 40 seconds…).

FastCGI: server “C:/Programmi/Apache
Group/Apache2/htdocs/fatturails/public/dispatch.fcgi” has failed to
remain running for 30 seconds given 3 attempts, its restart interval has
been backed off to 600 seconds

[Wed Feb 01 20:37:10 2006] [error] [client] (OS 2)Impossibile
trovare il file specificato. : FastCGI: failed to connect to server

CreateFile()/WaitNamedPipe() timed out
[Wed Feb 01 20:37:10 2006] [error] [client] FastCGI:
incomplete headers (0 bytes) received from server “C:/Programmi/Apache

Thans to all for the help.

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs