# Complancy with the IETF specifications (RFCs 1945, 2616 and 2396)

**URL:** <https://www.ruby-forum.com/t/complancy-with-the-ietf-specifications-rfcs-1945-2616-and-2396/226598>\
**Category:** NGINX\
**Created:** [December 26, 2012, 1:35pm UTC](https://www.ruby-forum.com/t/complancy-with-the-ietf-specifications-rfcs-1945-2616-and-2396/226598 "2012-12-26T13:35:26Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![parttis](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/p/76d3ee/32.png) [@parttis](https://www.ruby-forum.com/u/parttis)\
**Post date:** [December 26, 2012, 1:35pm UTC](https://www.ruby-forum.com/t/complancy-with-the-ietf-specifications-rfcs-1945-2616-and-2396/226598/1 "2012-12-26T13:35:26Z")

</div>

Hi

I am currently making a research related to different HTTP server  
implementations.

To make my research results complete, I would like to know if Nginx web  
server is fully compliant with the following IETF recommendations:

- HTTP/1.0 specification RFC 1945,
- HTTP/1.1 specification RFC 2616, and
- the URI generic syntax specification RFC 2396.

Thanks in advance.

Posted at Nginx Forum:

> **[Complancy with the IETF specifications (RFCs 1945, 2616 and 2396)](https://forum.nginx.org/read.php?2,234475,234475#msg-234475)**
>
> Hi I am currently making a research related to different HTTP server implementations. To make my research results complete, I would like to know if Nginx web server is fully compliant with the following IETF recommendations: \* HTTP/1.0 specification...

---

<div class="post-metadata">

**Author:** ![parttis](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/p/76d3ee/32.png) [@parttis](https://www.ruby-forum.com/u/parttis)\
**Post date:** [December 26, 2012, 2:12pm UTC](https://www.ruby-forum.com/t/complancy-with-the-ietf-specifications-rfcs-1945-2616-and-2396/226598/2 "2012-12-26T14:12:49Z")

</div>

On 26 December 2012 12:35, parttis [removed\_email\_address@domain.invalid](mailto:removed_email_address@domain.invalid) wrote:

> Hi
> 
> I am currently making a research related to different HTTP server  
> implementations.
> 
> To make my research results complete, I would like to know if Nginx web  
> server is fully compliant with the following IETF recommendations:
> 
> - HTTP/1.0 specification RFC 1945,
> - HTTP/1.1 specification RFC 2616, and
> - the URI generic syntax specification RFC 2396.

Isn’t the point of “research” that you actually, er, _research_ these  
things yourself?

For example, writing a test suite of clients and tests that you can  
point at various HTTP servers to discover their RFC/etc compliance  
levels?

## Jonathan

Jonathan M. // Oxford, London, UK

> **[Jonathan Matthews :: Words Typed, Great Rates For Cash](https://www.jpluscplusm.com)**
