Cannot Find Gem error

I’ve updated rails to 1.1.4, and have also done a ‘gem cleanup’ so
older versions are gone.

I went to a little app I had created back when I had 1.1.2. I tried to
do a

script/generate migration xxxx

and got an error:

Cannot find gem for Rails =1.1.2:
Install the missing gem with ‘gem install -v=1.1.2 rails’, or
change environment.rb to define RAILS_GEM_VERSION with your desired
version.

In the environment.rb file, there’s the lines:

Specifies gem version of Rails to use when vendor/rails is not

present
RAILS_GEM_VERSION = ‘1.1.2’

I suppose I can just change that, but… is that what is to be done
when updating Rails? Do I now have to do it with any other apps I’ve
got?

Doing a rake rails:update gives the same error.

Thanks for any help!

Yup, just change that to be 1.1.4.

On 7/2/06, Chris C. [email protected] wrote:

Yup, just change that to be 1.1.4.

I figured as much - must be something recent (as of 1.1.2?) I didn’t
have to touch environment.rb in previous updates.

Thanks

This forum is not affiliated to the Ruby language, Ruby on Rails framework, nor any Ruby applications discussed here.

| Privacy Policy | Terms of Service | Remote Ruby Jobs