# Bad ActiveSupport gem in gem repository?

**URL:** <https://www.ruby-forum.com/t/bad-activesupport-gem-in-gem-repository/89054>\
**Category:** Rails\
**Created:** [March 16, 2007, 8:00pm UTC](https://www.ruby-forum.com/t/bad-activesupport-gem-in-gem-repository/89054 "2007-03-16T20:00:32Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![weyus](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/w/7ab992/32.png) [@weyus](https://www.ruby-forum.com/u/weyus)\
**Post date:** [March 16, 2007, 8:00pm UTC](https://www.ruby-forum.com/t/bad-activesupport-gem-in-gem-repository/89054/1 "2007-03-16T20:00:32Z")

</div>

All,

I’m attempting to update my gems to 1.2 and I get the following:

Install required dependency activesupport? [Yn] Y  
ERROR: While executing gem … (Gem::InstallError)  
invalid gem format for  
c:/ruby/lib/ruby/gems/1.8/cache/activesupport-1.4.2.g  
em

Anyone else seeing this? Anyone willing to try it to see what’s up?

Thanks,  
Wes

---

<div class="post-metadata">

**Author:** ![weyus](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/w/7ab992/32.png) [@weyus](https://www.ruby-forum.com/u/weyus)\
**Post date:** [March 16, 2007, 8:15pm UTC](https://www.ruby-forum.com/t/bad-activesupport-gem-in-gem-repository/89054/2 "2007-03-16T20:15:19Z")

</div>

Wes G. wrote:

> All,
> 
> I’m attempting to update my gems to 1.2 and I get the following:
> 
> Install required dependency activesupport? [Yn] Y  
> ERROR: While executing gem … (Gem::InstallError)  
> invalid gem format for  
> c:/ruby/lib/ruby/gems/1.8/cache/activesupport-1.4.2.g  
> em
> 
> Anyone else seeing this? Anyone willing to try it to see what’s up?
> 
> Thanks,  
> Wes

Firewall issues on my side. Sorry to bother you.

WG

---

<div class="post-metadata">

**Author:** ![weyus](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/w/7ab992/32.png) [@weyus](https://www.ruby-forum.com/u/weyus)\
**Post date:** [March 16, 2007, 10:26pm UTC](https://www.ruby-forum.com/t/bad-activesupport-gem-in-gem-repository/89054/3 "2007-03-16T22:26:36Z")

</div>

In fact, neither Rubygems 0.9.1 nor 0.9.2 work on my Windows XP box. So  
I reverted back to 0.9.0 and all was well.

WG

---

<div class="post-metadata">

**Author:** ![weyus](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/w/7ab992/32.png) [@weyus](https://www.ruby-forum.com/u/weyus)\
**Post date:** [March 17, 2007, 12:47am UTC](https://www.ruby-forum.com/t/bad-activesupport-gem-in-gem-repository/89054/4 "2007-03-17T00:47:06Z")

</div>

Hi Wes,

Your question got me to check my Ruby\_1.8.2-15 installation on my  
WinXP-Pro/SP2 box.

K:\>gem -v =\> 0.9.0  
which AFIK has been working well.

K:\>echo %rubyopt% =\> rubygems rubygems  
Looks suspicious; should I cut it down to just rubygems?  
and what does it do, anyway?

K:\_Utilities\Ruby\_1.8.2-15\ruby\bin\>dir u\* =\> update\_rubygems.cmd  
(also plain update\_rubygems)  
Should I run this before I run gem to download something?  
Or does “gem update” run “update\_rubygems.cmd”?

TIA for any insights you may offer.

Regards,  
Richard

On Mar 16, 5:26 pm, Wes G. [removed\_email\_address@domain.invalid](mailto:removed_email_address@domain.invalid)

---

<div class="post-metadata">

**Author:** ![weyus](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/w/7ab992/32.png) [@weyus](https://www.ruby-forum.com/u/weyus)\
**Post date:** [March 20, 2007, 5:49am UTC](https://www.ruby-forum.com/t/bad-activesupport-gem-in-gem-repository/89054/5 "2007-03-20T05:49:52Z")

</div>

Hi Wes,

Great advice and info. They are much appreciated.

Best wishes,  
Richard

On Mar 17, 2:22 am, Wes G. [removed\_email\_address@domain.invalid](mailto:removed_email_address@domain.invalid)

---

<div class="post-metadata">

**Author:** ![weyus](https://www.ruby-forum.com/letter_avatar_proxy/v4/letter/w/7ab992/32.png) [@weyus](https://www.ruby-forum.com/u/weyus)\
**Post date:** [March 17, 2007, 7:22am UTC](https://www.ruby-forum.com/t/bad-activesupport-gem-in-gem-repository/89054/6 "2007-03-17T07:22:42Z")

</div>

> K:\>echo %rubyopt% =\> rubygems rubygems  
> Looks suspicious; should I cut it down to just rubygems?  
> and what does it do, anyway?

You should cut it down to just rubygems. It requires rubygems for the  
Ruby interpreter so that you don’t have to do it explicitly before you  
try to use a gem. In Rails, of course, you could just require  
‘rubygems’ in either environment.rb or application.rb and achieve the  
same “require at startup” effect.

> K:\_Utilities\Ruby\_1.8.2-15\ruby\bin\>dir u\* =\> update\_rubygems.cmd  
> (also plain update\_rubygems)  
> Should I run this before I run gem to download something?  
> Or does “gem update” run “update\_rubygems.cmd”?

I’ve never seen this and don’t know about it, which makes me assume that  
we don’t need to know about it ;).

Wes
