Forum: Ruby on Rails Unable to configure apache 1.3.29 for ruby

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
janakiraman (Guest)
on 2007-03-02 12:58

 I downloaded Ruby(Version:1.8.2-15) from and followed the instruction given
there. Everything went fine till creating the Rails application. But
when I ran the command ruby "C:\Program Files\Apache
Group\Apache2\htdocs\myfirstapp\script\server" ,I get an error. Iam
unable to start WEBrick HTTP server. But on the other hand when I click
start->programs->ruby->ruby182-15->ruby gems->startrubygemsrdocserver
Iam able to start the WEBrick HTTP server. I could see the port number
as 8808. so I just went to the browser and type http://localhost:8808 I
don't get "congrulations,you've put ruby on rails" rather I get
"RubyGems Documentation Index".

Iam using apache 1.3.29 version.

Added the below set of lines to hhtp.conf

1)I added LoadModule fastcgi_module modules/mod_fastcgi.dll
2)I added AddModule mod_fastcgi.c
3)<VirtualHost *:80>
  ServerName rails
  DocumentRoot "E:\Projects\myfirstapp\public"
  <Directory "E:\Projects\myfirstapp\public">
    Options ExecCGI FollowSymLinks
    AllowOverride all
    Allow from all
    Order allow,deny
    AddHandler cgi-script .cgi
    AddHandler fastcgi-script .fcgi

Afer doing this and when I type http://localhost/ I get "Welcome aboard
You’re riding the Rails!  Getting started Here’s how to get rolling:"

Iam not sure how to proceed next. Can anyone suggest me if iam in the
right direction and where I gone wrong.

This topic is locked and can not be replied to.