Forum: Ruby Installing .gem in an embedded system

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
unknown (Guest)
on 2007-03-01 11:06
(Received via mailing list)
Hi,
I am trying to install sqlite3-ruby-1.1.0.gem on an embedded system
(with
ARM cpu).

From the target I use the command
gem install sqlite3-ruby-1.1.0.gem
but the installation fail, saying that sqlite3.h cannot be found.

This is the mkmf.log:

--------- mkmf.log -----------

have_header: checking for sqlite3.h... -------------------- no

"arm-linux-gcc -E -I. -I/usr/local/lib/ruby/1.8/arm-linux -I.
-I/include/
-I/usr
checked program was:
/* begin */
1: #include <sqlite3.h>
/* end */

--------------------


It seems that the installation process wants a gcc compiler but on my
target I have not a toolchain.

How can I install sqlite3-ruby gem on my target without compiling?

Thanks ad regards.
Angelo Fontana

--

questo articolo e` stato inviato via web dal servizio gratuito
http://www.newsland.it/news segnala gli abusi ad 
removed_email_address@domain.invalid
Jan S. (Guest)
on 2007-03-01 15:21
(Received via mailing list)
On 3/1/07, Angelo <removed_email_address@domain.invalid> wrote:
> --------- mkmf.log -----------
> --------------------
>
>
> It seems that the installation process wants a gcc compiler but on my
> target I have not a toolchain.
>
> How can I install sqlite3-ruby gem on my target without compiling?

extract the sources, compile the extension where you have the
toolchain, and then repack with binary extension (inspire yourself
with -win32 gems -- typically win32 has no toolchain installed as
well)

I'll leave the details up to you ;-)
unknown (Guest)
on 2007-03-04 16:11
(Received via mailing list)
Jan S. ha scritto:

> >
> >
> > --------------------
> >
> >
> > It seems that the installation process wants a gcc compiler but on my
> > target I have not a toolchain.
> >
> > How can I install sqlite3-ruby gem on my target without compiling?

> extract the sources, compile the extension where you have the
> toolchain, and then repack with binary extension (inspire yourself
> with -win32 gems -- typically win32 has no toolchain installed as
> well)

> I'll leave the details up to you ;-)

I am not able to build a non-empty .gem, so I worked with .tar.gz
package.
I have crosscompiled the extension with the toolchain, I installed the
package in /tmp/sqlite3-ruby (with the command: ruby setup.rb install
--prefix=/tmp/sqlite3-ruby) and I copied /tmp/sqlite3-ruby on the
target.
Then I had to build an empty .gem, because sqlite3-ruby didn't appear in
the list of installed .gem on the target.
After the installation of the empty .gem, the package worked properly.

Now I should learn how to build a non-empty .gem! ;-)

Thanks you for your help!

Angelo.

--

questo articolo e` stato inviato via web dal servizio gratuito
http://www.newsland.it/news segnala gli abusi ad 
removed_email_address@domain.invalid
This topic is locked and can not be replied to.