Forum: Ruby on Rails undefined method `acts_as_attachment' for Photo:Class

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Scott (Guest)
on 2007-02-26 20:08
(Received via mailing list)
Hi,

I am trying to use the Acts as Attachment plugin and running into the
following error:

undefined method `acts_as_attachment' for Photo:Class

Here's the steps I took:

  script/plugin source http://svn.techno-weenie.net/projects/plugins
  script/plugin install acts_as_attachment
  script/generate attachment_model photo
  rake rails:freeze:gems

Here's my photo.rb file:

class Photo < ActiveRecord::Base
  belongs_to :product
  acts_as_attachment :storage => :file_system, :max_size =>
300.kilobytes, :content_type => :image
  validates_as_attachment
end

Any ideas?

Thanks,

Scott
Scott (Guest)
on 2007-02-26 21:38
(Received via mailing list)
Fixed it. For some reason, the script/plugin install
acts_as_attachment didn't seem to install properly. I ran it again and
it installed correctly the second time.

Scott
siegi (Guest)
on 2007-03-29 11:56
(Received via mailing list)
had the same problem. restarting the server helped.

siegi
This topic is locked and can not be replied to.