Forum: Ruby Problems installing libxml

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
veganjen (Guest)
on 2007-02-19 04:23
(Received via mailing list)
Hi, everyone,

I'm having trouble installing libxml-ruby and was hoping someone here
help. I've run into the same problem on both Mac OS X Tiger and Ubuntu
Dapper Drake (6.06 LTS).  I've most recently tried installing on Dapper
where I installed Ruby 1.8.5 from source.  I've tried both installing
gem for the latest stable release ( and also using the tarball
0.4.0pre01 (although the gem the Rakefile creates is called
libxml-ruby- Neither works.

Here's what I get when I try to install the development release:

> No definition for ruby_xml_html_parser_filename_get
> Enclosing class/module 'mXML' for class Reader not known
> Enclosing class/module 'mXML' for class Attribute not known
> No definition for input_callbacks_register_input_callbacks
> No definition for input_callbacks_add_scheme
> No definition for input_callbacks_remove_scheme

Any suggestions?

This topic is locked and can not be replied to.