Forum: Italian Ruby user group [installare plugins]

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Max D. (Guest)
on 2007-02-11 05:12
Salve

non riesco ad installare plugins. Quando eseguo il comando:

ruby script/plugin install svn://...

dalla root del progetto rails, semplicemente non succede nulla: il
prompt non riporta errori, la directory vendor\plugins rimane vuota.

Non avevo mai installato plugin, oggi ho eseguito l'update di gem:
gem 0.9.2
ruby 1.8.5
rails 1.2.1
su Windows
In seguito ho trovato un plugin che mi servirebbe, ma...

Adesso, quando uso

rails progetto
ruby script/plugin install svn://...
e
rails -v

ottengo il messaggio:

D:0:Warning: require_gem is obsolete.  Use gem instead.

Ho provato a modificare la riga 29 di boot.rb, da require_gem a gem, ma
cosi' risolvo solo il problema del messaggio di Warning. Continua non
installando i plugin.

Grazie
Max
stb (Guest)
on 2007-02-11 13:55
(Received via mailing list)
ho avuto anch' io questo problema con il plugin ym4r e non ne ho ancora
capito il motivo...

----- Original Message -----
From: "Max D." <removed_email_address@domain.invalid>
To: <removed_email_address@domain.invalid>
Sent: Sunday, February 11, 2007 4:12 AM
Subject: [ruby-it] [installare plugins]


> gem 0.9.2
> rails -v
> Max
>
> --
> Posted via http://www.ruby-forum.com/.
>


--------------------------------------------------------------------------------
Max D. (Guest)
on 2007-02-11 15:26
Si, il plugin e' proprio quello. Poi, per prova, ho tentato
l'installazione di altri plugin da svn e (per lo meno con i plugin
provati) il risultato e' stato comunque negativo. Riesco ad installare
solo nella forma:

script/plugin install nome_plugin

Per installare da svn, occorre qualche configurazione particolare?

> ho avuto anch' io questo problema con il plugin ym4r e non ne ho ancora
> capito il motivo...
stb (Guest)
on 2007-02-11 23:29
(Received via mailing list)
In allegato hai un' appllicazione vuota con il plugin installato, me l'
hanno passata e funziona tutto, a leggiti il tutorial su rails on the
road

Ciao

----- Original Message -----
From: "Max D." <removed_email_address@domain.invalid>
To: <removed_email_address@domain.invalid>
Sent: Sunday, February 11, 2007 2:26 PM
Subject: [ruby-it] Re: [installare plugins]


>> capito il motivo...
>
> --
> Posted via http://www.ruby-forum.com/.
>


--------------------------------------------------------------------------------
Max D. (Guest)
on 2007-02-12 00:06
Ciao
Ci sono riuscito: non installava il plugin perche' occorre installare
prima subversion :)

Scusa, ma in allegato non ho trovato nulla (o non lo vedo io?)

Sei riuscito a completare il tutorial su rails on the road? Ho dovuto
fare delle modifiche al codice perche' quello postato nel tutorial non
mi funzionava, ma ad un certo punto mi sono bloccato e non ne sto
venendo fuori.

Ancora grazie :)

stb wrote:
> In allegato hai un' appllicazione vuota con il plugin installato, me l'
> hanno passata e funziona tutto, a leggiti il tutorial su rails on the
> road
stb (Guest)
on 2007-02-12 00:15
(Received via mailing list)
Ciao,
mi sa che allora anch' io non ho il subversion installato cioè uno ce
l'ho
ma si vede che non gli va bene.

Il tutorial era da guardare giusto per farsi un' idea, ma tu sei mica
riuscito a far andare gli eventi sui marker? sulla mappa mi funziona ma
se
aggiungo l' evento click al marker non va e ho provato in più modi a
farglielo fare.

----- Original Message -----
From: "Max D." <removed_email_address@domain.invalid>
To: <removed_email_address@domain.invalid>
Sent: Sunday, February 11, 2007 11:06 PM
Subject: [ruby-it] Re: Re: [installare plugins]


>
> Ancora grazie :)
>
> stb wrote:
>> In allegato hai un' appllicazione vuota con il plugin installato, me l'
>> hanno passata e funziona tutto, a leggiti il tutorial su rails on the
>> road
>
> --
> Posted via http://www.ruby-forum.com/.
>


--------------------------------------------------------------------------------
Max D. (Guest)
on 2007-02-12 00:35
> mi sa che allora anch' io non ho il subversion

Si,occorre installarlo

> Il tutorial era da guardare giusto per farsi un' idea, ma tu sei mica
> riuscito a far andare gli eventi sui marker? sulla mappa mi funziona ma
> se
> aggiungo l' evento click al marker non va e ho provato in più modi a
> farglielo fare.

Mah, ho cominciato in questi giorni con rails, quindi... mi son fermato
un bel po' prima degli eventi sui marker :)

Puoi postarmi od inviarmi il tuo progetto? Cosi' lo potrei confrontare
col mio e vedere cosa mi sta andando storto. Ed arrivo piu' in fretta
agli eventi :D

In ogni caso, grazie ancora :)
stb (Guest)
on 2007-02-12 11:26
Max D. wrote:
>> mi sa che allora anch' io non ho il subversion
>
> Si,occorre installarlo
>
>> Il tutorial era da guardare giusto per farsi un' idea, ma tu sei mica
>> riuscito a far andare gli eventi sui marker? sulla mappa mi funziona ma
>> se
>> aggiungo l' evento click al marker non va e ho provato in più modi a
>> farglielo fare.
>
> Mah, ho cominciato in questi giorni con rails, quindi... mi son fermato
> un bel po' prima degli eventi sui marker :)
>
> Puoi postarmi od inviarmi il tuo progetto? Cosi' lo potrei confrontare
> col mio e vedere cosa mi sta andando storto. Ed arrivo piu' in fretta
> agli eventi :D
>
> In ogni caso, grazie ancora :)

passarti il cocide mi mette parecchio male, l' applicazione ormai è
enorme e il codice ym4r è sparso dentro di essa.
Max D. (Guest)
on 2007-02-12 21:36
Tranquillo, non era minha intenzione essere "invadente" :)

> passarti il cocide mi mette parecchio male, l' applicazione ormai è
> enorme e il codice ym4r è sparso dentro di essa.
stb (Guest)
on 2007-02-13 00:25
(Received via mailing list)
no no ma non è che voglio tenermelo tutto per me, non è niente di che
come
codice tutta roba semplice il casino è che ho pezzi in giro, se vuoi te
li
passo ma presi così non è che siano molto utili, per esempio ho usato
diverse tecniche, in alcune chiamate ho usato rjs in altre l' init
----- Original Message -----
From: "Max D." <removed_email_address@domain.invalid>
To: <removed_email_address@domain.invalid>
Sent: Monday, February 12, 2007 8:36 PM
Subject: [ruby-it] Re: Re: Re: [installare plugins]


> Tranquillo, non era minha intenzione essere "invadente" :)
>
>> passarti il cocide mi mette parecchio male, l' applicazione ormai è
>> enorme e il codice ym4r è sparso dentro di essa.
>
>
> --
> Posted via http://www.ruby-forum.com/.
>


--------------------------------------------------------------------------------
Max D. (Guest)
on 2007-02-13 00:48
Guarda te, a me farebbe comodo vedere qualcosa di + avanzato rispetto al
mio basico :)
Se decidi di postare il codice nel forum, dove lo posso trovare? Avevi
detto di aver allegato un progetto vuoto, ma non lho trovato.

stb wrote:
> no no ma non è che voglio tenermelo tutto per me, non è niente di che
> come
> codice tutta roba semplice il c asino è che ho pezzi in giro, se vuoi te
> li
> passo ma presi così non è che siano molto utili, per esempio ho usato
> diverse tecniche, in alcune chiamate ho usato rjs in altre l' init
This topic is locked and can not be replied to.