Forum: Ruby on Rails Functional tests broken in 1.2.2?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Ingo W. (Guest)
on 2007-02-08 23:00
Hi,

I upgraded to 1.2.2 and many of my functional tests broke. It seems like
passing stuff into the session using the following syntax doesn't work:

get :index, {}, {:user_id => '1'}

In the debugger I could clearly see that the :user_id didn't make it
into the session. Did the syntax for doing this change, or is this a
bug?

Ingo
Jeff C. (Guest)
on 2007-02-08 23:03
Ingo W. wrote:
> Hi,
>
> I upgraded to 1.2.2 and many of my functional tests broke. It seems like
> passing stuff into the session using the following syntax doesn't work:
>
> get :index, {}, {:user_id => '1'}
>
> In the debugger I could clearly see that the :user_id didn't make it
> into the session. Did the syntax for doing this change, or is this a
> bug?
>
> Ingo

I just posted about this a few minutes ago :)

Apparently the correct syntax is now:

@request.session[:user_id] = '1'
get :index

Jeff
Jeremy K. (Guest)
on 2007-02-08 23:13
(Received via mailing list)
On 2/8/07, Jeff C.man <removed_email_address@domain.invalid> wrote:
> > into the session. Did the syntax for doing this change, or is this a
> > bug?
> >
> > Ingo
>
> I just posted about this a few minutes ago :)
>
> Apparently the correct syntax is now:
>
> @request.session[:user_id] = '1'
> get :index


What Ingo has should work. This is a bug and will be fixed in 1.2.3!

Sorry for letting the regression slip in, all.

jeremy
Jeff C. (Guest)
on 2007-02-09 00:23
Jeremy K. wrote:
> On 2/8/07, Jeff C.man <removed_email_address@domain.invalid> wrote:
>> > into the session. Did the syntax for doing this change, or is this a
>> > bug?
>> >
>> > Ingo
>>
>> I just posted about this a few minutes ago :)
>>
>> Apparently the correct syntax is now:
>>
>> @request.session[:user_id] = '1'
>> get :index
>
>
> What Ingo has should work. This is a bug and will be fixed in 1.2.3!
>
> Sorry for letting the regression slip in, all.
>
> jeremy

Thanks, Jeremy!  I was wondering what had happened :)

Jeff
This topic is locked and can not be replied to.