Forum: Ruby ruby openssl bindings.

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Satish M. (Guest)
on 2007-01-24 03:04
Here is the error which I get when i try a code with line require
/usr/local/lib/ruby/1.8/net/https.rb:102:in `require': no such file to
load -- openssl (LoadError)
from /usr/local/lib/ruby/1.8/net/https.rb:102

I see that ruby-openssl bindings are not installed..
I have openssl-0.98d installed.

Steps i tried with no success..
I copies the include folder from /usr/local/ssl and copied into
rubysource folder/ext/openssl

and tried doing a
ruby extconf.rb

but I still get this new error.

checking for OpenSSL_add_all_digests() in -lcrypto... no
checking for OpenSSL_add_all_digests() in -llibeay32... no

help me please, this issue is on a godaddy virtual dedicated server...

how do i get a ruby app running which uses net/https??
This topic is locked and can not be replied to.