Forum: Ruby on Rails Rails 1.2.1 breaks all urls

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
donut d. (Guest)
on 2007-01-23 21:54
I've just upgraded from rails 1.1.6 to 1.2.1 and now I can't navigate to
any page of my site.  It seems that the controller gets called but my
browser says my page can't be found.  Each request result in the
following webrick output:

#<NameError: cannot remove Object::WildcardQuery>
["/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:423:in
`remove_const'",
"/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:423:in
`remove_constant'",
"/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:274:in
`remove_unloadable_constants!'",
"/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:274:in
`remove_unloadable_constants!'",
"/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:73:in
`clear'",
"/usr/local/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/dispatcher.rb:60:in
`reset_application!'",
"/usr/local/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/dispatcher.rb:116:in
`reset_after_dispatch'",
"/usr/local/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/dispatcher.rb:51:in
`dispatch'",
"/usr/local/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/webrick_server.rb:113:in
`handle_dispatch'",
"/usr/local/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/webrick_server.rb:79:in
`service'", "/usr/local/lib/ruby/1.8/webrick/httpserver.rb:104:in
`service'", "/usr/local/lib/ruby/1.8/webrick/httpserver.rb:65:in `run'",
"/usr/local/lib/ruby/1.8/webrick/server.rb:173:in `start_thread'",
"/usr/local/lib/ruby/1.8/webrick/server.rb:162:in `start_thread'",
"/usr/local/lib/ruby/1.8/webrick/server.rb:95:in `start'",
"/usr/local/lib/ruby/1.8/webrick/server.rb:92:in `start'",
"/usr/local/lib/ruby/1.8/webrick/server.rb:23:in `start'",
"/usr/local/lib/ruby/1.8/webrick/server.rb:82:in `start'",
"/usr/local/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/webrick_server.rb:63:in
`dispatch'",
"/usr/local/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/commands/servers/webrick.rb:59",
"/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'",
"/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:496:in
`require'",
"/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:343:in
`new_constants_in'",
"/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:496:in
`require'",
"/usr/local/lib/ruby/gems/1.8/gems/rails-1.2.1/lib/commands/server.rb:39",
"/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'",
"/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:496:in
`require'",
"/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:343:in
`new_constants_in'",
"/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:496:in
`require'", "script/server:3"]
[2007-01-23 11:50:29] ERROR `/market/list' not found.
192.168.1.102 - - [23/Jan/2007:11:50:29 PST] "GET /market/list HTTP/1.1"
404 283
- -> /market/list

Any help is appreciated.  I can't seem to be able to go back to rails
1.1.6 since installing rails 1.2.1 also installs all its dependencies.
My dev work came to a halt...
donut d. (Guest)
on 2007-01-24 02:24
I've spent hours on this.  If I restart webrick, I get a different error
on when accessing an url:

#<NameError: cannot remove Object::QueryFilter>
["/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:423:in
`remove_const'",
"/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:423:in
`remove_constant'",
"/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:274:in
`remove_unloadable_constants!'",
"/usr/local/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:274:in
`remove_unloadable_constan


I can't believe no one has seen this...
François B. (Guest)
on 2007-01-24 16:30
(Received via mailing list)
Hi,

2007/1/23, donut donut <removed_email_address@domain.invalid>:
> #<NameError: cannot remove Object::WildcardQuery>

What is WildcardQuery ?  Is it a plugin ?  That's where I'd start
investigating if I were you.  Since no one has replied, it seems no
one has the same kind of problem.

Hope that helps.

Bye !
--
François Beausoleil
http://blog.teksol.info/
http://piston.rubyforge.org/
Jeremy K. (Guest)
on 2007-01-24 17:09
(Received via mailing list)
On 1/24/07, Francois B. <removed_email_address@domain.invalid> wrote:
>
> Bye !

I'd guess it's an acts_as_search_engine plugin that does include
MyParentModule in the toplevel?

See http://dev.rubyonrails.org/ticket/6951

jeremy
unknown (Guest)
on 2007-01-24 18:16
(Received via mailing list)
On 1/23/07, donut donut <removed_email_address@domain.invalid> wrote:
> I've just upgraded from rails 1.1.6 to 1.2.1 and now I can't navigate to
> any page of my site.  ...
>
> Any help is appreciated.  I can't seem to be able to go back to rails
> 1.1.6 since installing rails 1.2.1 also installs all its dependencies.
> My dev work came to a halt...

What platform are you running on?  How was Rails installed (gem?)?
How are you trying to switchback to 1.1.6?  And, what error occurs in
that process?

Thanks.
Gustav P. (Guest)
on 2007-01-24 18:35
(Received via mailing list)
Try downloading the rails 1.1.6 tgz from the rubyforge download page,
extract the contents and copy the extracted vendor/rails directory to
your project's RAILS_ROOT/vendor/ directory, this should overwrite the
installed gem version with the rails version in your vendor directory
(aka 1.1.6)

ie.
dir (or ls, etc) RAILS_ROOT/vendor/
(should result in)
.. rails/
.. plugins/

then:
dir RAILS_ROOT/vendor/rails/
(should result in)
.. actionmailer/
.. actionpack/
.. activerecord/
.. etc.

Ciao
Gustav P.
Conrad T. (Guest)
on 2007-01-24 20:54
(Received via mailing list)
Hi, did you do the following to migrate your project from 1.1.6 to
1.2.1:

a)  update you environment.rb file to use 1.2.1

b)  rake rails:update

-Conrad
donut d. (Guest)
on 2007-01-24 21:16
Conrad T. wrote:
> Hi, did you do the following to migrate your project from 1.1.6 to
> 1.2.1:
>
> a)  update you environment.rb file to use 1.2.1
>
> b)  rake rails:update
>
> -Conrad

I've reverted back to 1.1.6 for the moment(I couldn't before coze I made
the version change in environment.rb but I forgot to save the file!).

I've done (a) but not (b).  (b) looks scary as I guess (b) will
overwrite various files in my project.  Can I undo the changes if I want
to go back to 1.1.6?

It turns out the WildcardQuery and QueryFilter classes belong to ferret
and I used ferret and act as ferret.  The strange thing is that if I hit
a page/model that doesn't use ferret, things work.  However, as soon as
I go to a page that uses a class that uses ferret, then all hell breaks
lose and then nothing loads from then on, not even a page/model with no
ferret usage.  I stepped thru the code and ActiveRecord would not work
at this point(most if not all model methods would fail).  I would need
to restart webrick at this point.
Mark C. (Guest)
on 2007-01-24 21:33
(Received via mailing list)
You should be using some form of version control system, so that if
things
like these upgrades break then you can easily roll back.

If you don't have access to a version control system,
http://opensvn.csie.org offers free (as in beer) svn and trac to those
who
sign up, however they are located in Taiwan and connection speed isn't
what
you call screaming if yer in the states.  Still it is free so you can't
complain.

Mark<><
Evan (Guest)
on 2007-01-24 21:41
(Received via mailing list)
or you could do `gem install -v=1.1.6 rails` and edit your
ENV['RAILS_VERSION'] to 1.1.6 in your config/environment.rb.  easier
done this way.  no need for freezing your rails gems.
donut d. (Guest)
on 2007-01-30 21:31
Rails 1.2.1 seems to have broken a lot of gems.  My first problem was
related to the ferret and acts_as_ferret gems.  After upgrading these
gems to the latest and the greatest, the ferret problems went away but
now rails is complaining about my RMagick gem.  I'm not sure if there'll
be more problems even after I upgrade RMagick.  I'm not sure if it's
worth the time to go through all the compatibility problems when 1.1.6
works fine for me.  After seeing that 1.2.1 is as least 50% slower than
1.1.6 ( see http://www.ruby-forum.com/topic/95947#new ), I'm just gonna
stick with 1.1.6 for now.
This topic is locked and can not be replied to.