Forum: Ruby another wierd error whilst installing gems?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
libsfan01 (Guest)
on 2007-01-22 03:20
(Received via mailing list)
what could cause this error in terminal when updating gems?

Bulk updating Gem source index for: http://gems.rubyforge.org
ERROR:  While executing gem ... (Errno::EACCES)
    Permission denied -
/usr/lib/ruby/gems/1.8/cache/rb-appscript-0.3.0.gem
[marcrice:~] marcrice%


please help!
Timothy H. (Guest)
on 2007-01-22 03:31
(Received via mailing list)
libsfan01 wrote:
>
>
>
Well, going by the "permission denied" message I'd guess that you don't
have the access rights to the directory. On my Linux box, at least, I
have to have root authority to modify anything in /usr. Perhaps you need
to log on as root or use sudo when you execute the gem command?
This topic is locked and can not be replied to.