Forum: Ruby on Rails mephisto syntax highlighting plugin broken with javascript?

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Elliott B. (Guest)
on 2007-01-19 02:48
Hi,

This is a rather narrow question, but, I can not think of a better place
to post it.(I thought http://mephisto.stikipad.com/ was a good choice,
but it is a wiki and not a forum.  (If anyone knows of a good
mephisto-specific forum, I would appreciate knowing about it.))

Anyway, my question is this:

I installed the code higlighter pluging by Dan W. via:
 script/plugin install
http://svn.danwebb.net/external/rails/plugins/filt...

Then I dealt with the broken install with the excellent assistance of
this help:

blog.wetonrails.com/2006/10/9/installing-the-codehighlighter

Ostensibly, this plug-in provides client-side syntax highlighting for
html,css,javascript and ruby. The only problem is that the syntax
hightlighting for javascript seems to be broken.  Has anybody
experienced this problem?

I'd be curious to know if any solutions/fixes have been found.

Thanks,
Elliott
Rick O. (Guest)
on 2007-01-19 17:31
(Received via mailing list)
On 1/18/07, Elliott B. <removed_email_address@domain.invalid> wrote:
>
> Hi,
>
> This is a rather narrow question, but, I can not think of a better place
> to post it.(I thought http://mephisto.stikipad.com/ was a good choice,
> but it is a wiki and not a forum.  (If anyone knows of a good
> mephisto-specific forum, I would appreciate knowing about it.))

There's a mephisto google group:
http://groups-beta.google.com/group/MephistoBlog

>
> Ostensibly, this plug-in provides client-side syntax highlighting for
> html,css,javascript and ruby. The only problem is that the syntax
> hightlighting for javascript seems to be broken.  Has anybody
> experienced this problem?
>
> I'd be curious to know if any solutions/fixes have been found.

Probably going to need more info than 'seems to be broken'.  It's in
use successfully on several sites that I know of.

--
Rick O.
http://weblog.techno-weenie.net
http://mephistoblog.com
Elliott B. (Guest)
on 2007-01-19 18:04
Hi Rick,


I found the problem.  It was another one of my idiot blunders. I had
neglected to include the include line for javascript syntax.  The sad
part of it is that I looked for this specific problem at least six
times, and missed it every single time.  I had copied the code and just
assumed it was correct. My bad.


{{ 'codehighlighter/code_highlighter' | javascript }}
{{ 'codehighlighter/javascript' | javascript }}  <<------I didn't have
this line
{{ 'codehighlighter/html' | javascript }}
{{ 'codehighlighter/ruby' | javascript }}
{{ 'codehighlighter/css' | javascript }}
{{ 'codehighlight' | stylesheet }}


Anyway, it all works now.

Thanks again,

Elliott
This topic is locked and can not be replied to.