Forum: Ruby on Rails SMTP behavior different in different actions

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Tom L. (Guest)
on 2007-01-17 21:53
(Received via mailing list)
Hi All,

I send e-mails at a few different points in my rails app, and I use the
exceptionnotifier plugin which works great.  I've run into a problem I
just can't figure out.  I just added an action so that people can send
me feedback via a form, and whenever I try to run it, I get an SMTP
error:

550 unknown user
/usr/lib/ruby/1.8/net/smtp.rb:680:in `check_response'

The part I don't understand is that this is in the SAME CONTROLLER as
other actions that are sending mail fine, on the same machine, in the
same environment.  Not only that, but the reason I know I'm getting
this error is that the exceptionnotifier plugin is e-mailing me that
fact.

Can anyone think of a reason on how this behavior could be different
between two actions on the same controller?  Everything looks the same
to me.  I can provide more information if people need it.  I've just
looked through the code and nothing looks out of whack.  It just looks
like another method, and another action.   Everything works fine in
development also (not using smtp).  It's only in production that I see
this problem.

Thanks!
Tom L.
This topic is locked and can not be replied to.