Forum: Italian Ruby user group [FIREBIRD] Aggiornamento a RUBY 1.8.4 ......( RMagick )

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Paolo G. (Guest)
on 2007-01-17 12:15
Ciao
sto sviluppando un progetto usando Ruby on Rails, con Firebird 2.0 come
Data Base.
Usando queste versioni di GEM il sistema è stabile:
RUBY:   1.8.2
RAILS:  1.1.2
ACTIVE-RECORD:  1.14.2
FIRERUBY:  0.4.1
RUBY-GEMS: 0.8.10

Ora ho bisogno di aggiornare RUBY alla versione 1.8.4, perchè ho bisogno
di usare Rmagick per generare i CODICI A BARRE.
Ho installato Ruby 1.8.4 ma ora quando interrogo il DB Ruby va in crash
...
Può essere un problema di compatibilità tra l'adpter di Firebird e Ruby?
Qualcuno ha qualche suggerimento da darmi per affrontare e risolvere il
problema?
stb (Guest)
on 2007-01-17 12:43
(Received via mailing list)
scusa ma ruby 1.8.4 contiene già rmagick? chiedo poichè ho una versione
prrecedente e ho avuto difficolta ad installare rmagick

----- Original Message -----
From: "Paolo G." <removed_email_address@domain.invalid>
To: <removed_email_address@domain.invalid>
Sent: Wednesday, January 17, 2007 11:15 AM
Subject: [ruby-it] [FIREBIRD] Aggiornamento a RUBY 1.8.4 ......( RMagick
)


> Ora ho bisogno di aggiornare RUBY alla versione 1.8.4, perchè ho bisogno
> di usare Rmagick per generare i CODICI A BARRE.
> Ho installato Ruby 1.8.4 ma ora quando interrogo il DB Ruby va in crash
> ...
> Può essere un problema di compatibilità tra l'adpter di Firebird e Ruby?
> Qualcuno ha qualche suggerimento da darmi per affrontare e risolvere il
> problema?
>
> --
> Posted via http://www.ruby-forum.com/.
>


--------------------------------------------------------------------------------
Paolo G. (Guest)
on 2007-01-17 12:57
no, non lo contiene. Va installato in seguito.
rmagick, che io sappia, si può installare a partire da RUBY 1.8.4 ... è
per quello che devo fare l'aggiornamento, solo che facendolo ho qualche
problema con il data base.
Tu sei riuscto ad installarlo anche con RUBY 1.8.2?


> scusa ma ruby 1.8.4 contiene già rmagick? chiedo poichè ho una versione
> prrecedente e ho avuto difficolta ad installare rmagick
>
> ----- Original Message -----
> From: "Paolo G." <removed_email_address@domain.invalid>
> To: <removed_email_address@domain.invalid>
> Sent: Wednesday, January 17, 2007 11:15 AM
> Subject: [ruby-it] [FIREBIRD] Aggiornamento a RUBY 1.8.4 ......( RMagick
> )
>
>
>> Ora ho bisogno di aggiornare RUBY alla versione 1.8.4, perchè ho bisogno
>> di usare Rmagick per generare i CODICI A BARRE.
>> Ho installato Ruby 1.8.4 ma ora quando interrogo il DB Ruby va in crash
>> ...
>> Può essere un problema di compatibilità tra l'adpter di Firebird e Ruby?
>> Qualcuno ha qualche suggerimento da darmi per affrontare e risolvere il
>> problema?
>>
>> --
>> Posted via http://www.ruby-forum.com/.
>>
>
>
> --------------------------------------------------------------------------------
Paolo G. (Guest)
on 2007-01-17 13:19
faccio una rettifica
RUBY 1.8.4 --> contiene già RMagick
RUBY 1.8.2 --> non c'è una versione per Windows :( .. se la trovate fate
un fischio :)

> no, non lo contiene. Va installato in seguito.
> rmagick, che io sappia, si può installare a partire da RUBY 1.8.4 ... è
> per quello che devo fare l'aggiornamento, solo che facendolo ho qualche
> problema con il data base.
> Tu sei riuscto ad installarlo anche con RUBY 1.8.2?
>
>
>> scusa ma ruby 1.8.4 contiene già rmagick? chiedo poichè ho una versione
>> prrecedente e ho avuto difficolta ad installare rmagick
stb (Guest)
on 2007-01-17 13:44
(Received via mailing list)
nn ho ancora provato

----- Original Message -----
From: "Paolo G." <removed_email_address@domain.invalid>
To: <removed_email_address@domain.invalid>
Sent: Wednesday, January 17, 2007 11:57 AM
Subject: [ruby-it] Re: [FIREBIRD] Aggiornamento a RUBY 1.8.4 ......(
RMagick)


>> ----- Original Message -----
>>> ...
>
>
> --
> Posted via http://www.ruby-forum.com/.
>


--------------------------------------------------------------------------------
Sij (Guest)
on 2007-01-17 13:48
Paolo G. wrote:
> Ciao
> sto sviluppando un progetto usando Ruby on Rails, con Firebird 2.0 come
> Data Base.
> Usando queste versioni di GEM il sistema è stabile:
> RUBY:   1.8.2
> RAILS:  1.1.2
> ACTIVE-RECORD:  1.14.2
> FIRERUBY:  0.4.1
> RUBY-GEMS: 0.8.10
>
Se ti può servire io uso senza problemi

> RUBY:   1.8.4
> RAILS:  1.1.6
> FIRERUBY:  0.4.1
Massimiliano M. (Guest)
on 2007-01-17 15:01
(Received via mailing list)
On 1/17/07, Paolo G. <removed_email_address@domain.invalid> wrote:
> Può essere un problema di compatibilità tra l'adpter di Firebird e Ruby?
> Qualcuno ha qualche suggerimento da darmi per affrontare e risolvere il
> problema?

Se si connette a Firebird attraverso una libreria binaria,
quest'ultima *potrebbe* dover essere ricompilata.

(Attenzione anche a Rails, stai usando una versione vulnerabile.)


--
Massimiliano M.
code: http://dev.hyperstruct.net
blog: http://blog.hyperstruct.net
Paolo G. (Guest)
on 2007-01-17 15:43
Hai modificato l'adapter di FIREBIRD per caso?
Che versione di FIREBIRD usi? La 1.5 o la 2.0?

Io ho seguito questa procedura:
1) ho installato RUBY: 1.8.4 con l'eseguibile scaricato da
http://rubyforge.org/frs/?group_id=167
2) dal prompt del DOS installo RAILS e ACTIVE RECORD: gem install rails
3) installo pdf-writer: gem install pdf-writer
4) FIRERUBY: gem install fireruby
5) copio in C:\Programmi\Firebird\Firebird_2_0\UDF la libreria
FreeUDFLib.dll
6) copio in C:\WINDOWS\system32 la libreria fbclient.dll
Fai anche tu lo stesso?


> Paolo G. wrote:
>> Ciao
>> sto sviluppando un progetto usando Ruby on Rails, con Firebird 2.0 come
>> Data Base.
>> Usando queste versioni di GEM il sistema è stabile:
>> RUBY:   1.8.2
>> RAILS:  1.1.2
>> ACTIVE-RECORD:  1.14.2
>> FIRERUBY:  0.4.1
>> RUBY-GEMS: 0.8.10
>>
> Se ti può servire io uso senza problemi
>
>> RUBY:   1.8.4
>> RAILS:  1.1.6
>> FIRERUBY:  0.4.1
Sij (Guest)
on 2007-01-17 17:32
Paolo G. wrote:
> Hai modificato l'adapter di FIREBIRD per caso?
> Che versione di FIREBIRD usi? La 1.5 o la 2.0?

1.5
Paolo G. (Guest)
on 2007-01-24 16:17
Sono riuscito ad installare RUBY 1.8.5 con Firebird 2.0. Urra!!!
Ho seguito le istruzioni del sito ufficiale:
http://www.rubyonrails.org/down
  :))

> Paolo G. wrote:
>> Hai modificato l'adapter di FIREBIRD per caso?
>> Che versione di FIREBIRD usi? La 1.5 o la 2.0?
>
> 1.5
Sij (Guest)
on 2007-01-24 20:07
Paolo G. wrote:
> Sono riuscito ad installare RUBY 1.8.5 con Firebird 2.0. Urra!!!
> Ho seguito le istruzioni del sito ufficiale:
> http://www.rubyonrails.org/down
>   :))

Buona notizia.

Quale S.O. usi ?

Ciao
Paolo G. (Guest)
on 2007-01-25 11:56
Come S.O. uso WinXP Professional... ho dovuto modificare qualche file di
ruby(firebird_adpter.rb, base.rb, schema_definitions.rb).
L'unico problema che ho ancora è con i LINK_TO_REMOTE che passano un
PARAMETRO, ad esempio:

<%= link_to_remote("<input name='selezionato' id='#{contatore_riga}'
type='radio' value='#{contatore_riga}' />", :update => 'nome_div', :url
=> {:action => 'pulsanti', :id => "#{dipendente['prg']}" }) %>


> Paolo G. wrote:
>> Sono riuscito ad installare RUBY 1.8.5 con Firebird 2.0. Urra!!!
>> Ho seguito le istruzioni del sito ufficiale:
>> http://www.rubyonrails.org/down
>>   :))
>
> Buona notizia.
>
> Quale S.O. usi ?
>
> Ciao
Luca M. (Guest)
on 2007-01-25 12:15
(Received via mailing list)
ciao Paolo,

Paolo G. wrote:
> Come S.O. uso WinXP Professional... ho dovuto modificare qualche file di
> ruby(firebird_adpter.rb, base.rb, schema_definitions.rb).
> L'unico problema che ho ancora è con i LINK_TO_REMOTE che passano un
> PARAMETRO, ad esempio:
>
> <%= link_to_remote("<input name='selezionato' id='#{contatore_riga}'
> type='radio' value='#{contatore_riga}' />", :update => 'nome_div', :url
> => {:action => 'pulsanti', :id => "#{dipendente['prg']}" }) %>

Non ho ben capito cosa stai cercando di ottenere qui... vuoi avere un
link attorno ad un radio button? Non e' piu semplice/chiaro mettersi in
ascolto sugli eventi di "change" del radio button e chiamare una
funzione remota?

Luca
--

Web:   http://spazidigitali.com - http://thetyper.com
Email mailto://removed_email_address@domain.invalid
Skype callto://l.mearelli
Paolo G. (Guest)
on 2007-01-25 12:49
Ciao Luca,
e' per ottenere un effetto grafico ... comunque ho risolto usando al
posto del :id il :with

<%= link_to_remote("<input name='selezionato' id='#{contatore_riga}'
type='radio' value='#{contatore_riga}' />", :update => 'nome_div', :url
=> {:action => 'pulsanti'}, :with => "'prg='+#{dipendente['prg']}") %>

Avendo fatto l'aggiornamento di Rails da 1.1.2 a 1.2.1 alcune cose sono
cambiate.Ho trovato la soluzione quì:
http://railsmanual.com/module/ActionView::Helpers:...

   Paolo

> ciao Paolo,
>
> Paolo G. wrote:
>> Come S.O. uso WinXP Professional... ho dovuto modificare qualche file di
>> ruby(firebird_adpter.rb, base.rb, schema_definitions.rb).
>> L'unico problema che ho ancora è con i LINK_TO_REMOTE che passano un
>> PARAMETRO, ad esempio:
>>
>> <%= link_to_remote("<input name='selezionato' id='#{contatore_riga}'
>> type='radio' value='#{contatore_riga}' />", :update => 'nome_div', :url
>> => {:action => 'pulsanti', :id => "#{dipendente['prg']}" }) %>
>
> Non ho ben capito cosa stai cercando di ottenere qui... vuoi avere un
> link attorno ad un radio button? Non e' piu semplice/chiaro mettersi in
> ascolto sugli eventi di "change" del radio button e chiamare una
> funzione remota?
>
> Luca
> --
>
> Web:   http://spazidigitali.com - http://thetyper.com
> Email mailto://removed_email_address@domain.invalid
> Skype callto://l.mearelli
This topic is locked and can not be replied to.