Forum: Ruby on Rails Rake doesn't load test DB

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Will Emigh (Guest)
on 2007-01-11 19:45
I created a new app with edge Rails and everything worked fine until I
created a model and ran my tests.  All of the tests errored out because
they couldn't find the model's table in the database.

When I ran rake --trace, I got this before all my errors:
** Invoke default (first_time)
** Invoke test (first_time)
** Execute test
** Invoke test:units (first_time)
** Invoke db:test:prepare (first_time)
** Invoke environment (first_time)
** Execute environment
** Execute db:test:prepare
** Invoke db:test:clone (first_time)
** Invoke db:schema:dump (first_time)
** Invoke environment
** Execute db:schema:dump
** Invoke db:test:purge (first_time)
** Invoke environment
** Execute db:test:purge
** Invoke test:functionals (first_time)
** Invoke db:test:prepare

It doesn't look like rake is actually loading the schema into the test
database, since I don't see db:schema:load anywhere in there and when I
check the database, it's empty.

Why is rake skipping the schema loading step?  Any help will be much
This topic is locked and can not be replied to.