Forum: Ruby rubygems

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
ara.t.howard (Guest)
on 2005-11-21 04:29
(Received via mailing list)
[ahoward@jib ~]$ diff -u rubygems.rb.org rubygems.rb
--- rubygems.rb.org  2005-11-20 19:16:41.000000000 -0700
+++ rubygems.rb      2005-11-20 19:16:53.000000000 -0700
@@ -131,7 +131,7 @@
      def activate(gem, autorequire, *version_requirements)
        @loaded_specs ||= Hash.new
        unless version_requirements.size > 0
-        version_requirements = ["> 0.0.0"]
+        version_requirements = [">= 0.0.0"]
        end
        unless gem.respond_to?(:name) &&
gem.respond_to?(:version_requirements)
          gem = Gem::Dependency.new(gem, version_requirements)



some of use actually use that one ;-)

-a
This topic is locked and can not be replied to.