Forum: Ruby Lots of getaddrinfo: Temporary failure in name resolution in

Announcement (2017-05-07): is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see and for other Rails- und Ruby-related community platforms.
Curtis Spencer (Guest)
on 2006-06-10 01:29
(Received via mailing list)

 I am working on a crawler, and I am encountering a large number of
 getaddrinfo: Temporary failure in name resolution exceptions when I am
 using open-uri.  I am using a hybrid approach with a lot of forks and
 lot of ruby threads running inside each process.  Each of these is
 making a open-uri calls.  Is there something I should be doing to
 ensure the proper DNS resolution is occuring.  When I dig the sites
 manually, all of them return a proper DNS entry.

 Secondly, I have tried the ruby resolver, and that gave poor resolution
 as well.  I have tried this on both my linux machine and OS X, both
 running ruby 1.8.4.

 Any ideas?
This topic is locked and can not be replied to.