Forum: Ruby on Rails blank division after update

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Dorian (Guest)
on 2006-06-09 22:09
Hello all,

     Im having a slight problem with my website.  I have a division that
is updated using a link_to_remote call.  Now, inside the view I can put
plain text and everything is fine.  However, if I try to pass a variable
from the controller to the view it does not work.  For example I can
have this as the controller:

def show_news
@testvariable = "shizzlenitboo"
end

And inside the view I can put
<%= @shizzlenitboo %>

Yet nothing will display.  Does anyone know what is causing this?
Charlie B. (Guest)
on 2006-06-09 22:17
(Received via mailing list)
Is this a typo?
<%= @shizzlenitboo %> shouldn't it be <%= @testvariable %>


On Fri, 2006-06-09 at 20:09 +0200, Dorian wrote:

> end
>
> And inside the view I can put
> <%= @shizzlenitboo %>
>
> Yet nothing will display.  Does anyone know what is causing this?
>

Charlie B.
Programmer
Castle Branch Inc.
Dorian (Guest)
on 2006-06-09 22:21
right,

     my fault I meant to say inside the view I could have

<%= @testvariable %>

and it will not display the contents of this variable in the division.
Its just blank.

Charlie B. wrote:
> Is this a typo?
> <%= @shizzlenitboo %> shouldn't it be <%= @testvariable %>
>
>
> On Fri, 2006-06-09 at 20:09 +0200, Dorian wrote:
>
>> end
>>
>> And inside the view I can put
>> <%= @shizzlenitboo %>
>>
>> Yet nothing will display.  Does anyone know what is causing this?
>>
>
> Charlie B.
> Programmer
> Castle Branch Inc.
This topic is locked and can not be replied to.