Forum: Ruby Re: FXRuby - textedit.rb example crash problem

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
unknown (Guest)
on 2006-06-03 12:02
(Received via mailing list)
> I  am writing a GUI. I need some bigger subfield with an editor in
> it. So  I tried to incorporate the textedit.rb example
>  (FXRuby-1.6.0,fox-1.4.33,Ruby 1.8.4).

FXRuby 1.6 requires FOX 1.6.5 or  later and won't work with FOX 1.4.33.
I'm a little curious about how you  managed to compile FXRuby-1.6.0
against fox-1.4.33 in the first  place...

You're right, I realize just now that I should have upgraded FOX in  the
first place. Yet the installation just worked using configure-make-make
install
for FOX and ruby setup.rb config etc.

I only upgraded in the first place because when I use FXRuby, I
quite frequently get Segmentation faults under Cygwin. This
happens for instance when calling foxGUib (in Linux, that's ok). I
posted
about
this already, and it seems that it's somehow the fault of FXRuby and
Cygwin
talking
together, but nobody knew anything more specific.


>  But when I enter text in it and use a backspace to
> correct some typo,  the program immediately stops
> with error: FXRbText::extractText : bad  argument (in Redhat Linux),
> if I use it under Cygwin(Windows XP), it  crashes after entering the first
> letter into the editor window (see  error file below).
> What's wrong here?

Not sure, but it sounds  like something you might want to file a bug
report about:

_http://rubyforge.org/tracker/?atid=1223&group_id=3...
(http://rubyforge.org/tracker/?atid=1223&group_id=3...)

I'll still experiment a bit to find out a good error description.... and
then
submit a bug report.

Thanks,

Axel



For  the time being, I'd recommend backing off to FXRuby 1.4, which is
the  stable release of FXRuby.
This topic is locked and can not be replied to.