Forum: Ruby ri broken

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Warren S. (Guest)
on 2006-05-28 02:51
(Received via mailing list)
RI does not produce useful output.

>ri Kernel.format
More than one method matched your request. You can refine
your search by asking for information on one of:

     Kernel#format, Kernel#format

>ri --version
ri v1.0.1 - 20041108

>ruby --version
ruby 1.8.4 (2005-12-24) [i386-mswin32]

FXRI isn't any better of course.  Clicking on something in the left
column just pastes it
into the irb window.  There is no help.

Warren Fred
Minkoo S. (Guest)
on 2006-05-28 22:47
(Received via mailing list)
You should say 'ri Kernel#format' instead of 'ri Kernel.format'.
Also, keep in mind that you should run 'make doc_install' when
you manually build ruby.

Sincerely,
Minkoo S.
This topic is locked and can not be replied to.