Forum: Ruby on Rails Problem with Rcov and Functional Tests

Announcement (2017-05-07): www.ruby-forum.com is now read-only since I unfortunately do not have the time to support and maintain the forum any more. Please see rubyonrails.org/community and ruby-lang.org/en/community for other Rails- und Ruby-related community platforms.
Stephen M. (Guest)
on 2006-05-27 05:40
I'm having a problem with Rcov 0.40 and Rails 1.1.2.  When I run all my
tests (unit, functional and integration) with rcov weird things happen
with some but not all of my functional tests.  The tests will blow up
with an 'ActionController::UnknownAction - no action responsed to
my_action' error.  After investigating and adding some print statements,
it turns out that in my WeeklyLineupControllerTest, when  I do a 'get'
or 'post' in the test, it actually invokes get or post on another
controller, different from the controller under test, like
HomeController.

I checked and double checked the @controller =
WeeklyLineupController.new line in my setup method.  And I run the test
just fine standalone, or as part of running all the tests via the rake
default task.  And if I break my rcov tasks out into 3 separate tasks,
one that runs unit tests, another functional, and another integration,
everything runs perfect.  The only disadvantage to that is that I can't
get a total coverage number.

Any help would be appreciated!

Thanks

Steve
This topic is locked and can not be replied to.